chainId may be outdated if user changes chains as part of connection in @web3-react
CVE-2023-30543GHSA-8pf3-6fgr-3g3g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@web3-react/coinbase-wallet 8.0.35-beta.0; @web3-react/walletconnect 8.0.37-beta.0; @web3-react/metamask 8.0.30-beta.0; @web3-react/eip1193 8.0.27-beta), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @web3-react/coinbase-wallet
- Affected
- >= 6.0.0, < 8.0.35-beta.0
- Fixed in
- 8.0.35-beta.0
- Affected
- >= 6.0.0, < 8.0.37-beta.0
- Fixed in
- 8.0.37-beta.0
- Affected
- >= 6.0.0, < 8.0.30-beta.0
- Fixed in
- 8.0.30-beta.0
- Affected
- >= 6.0.0, < 8.0.27-beta
- Fixed in
- 8.0.27-beta
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8pf3-6fgr-3g3g lists affected ranges: npm @web3-react/coinbase-wallet >=6.0.0 =6.0.0 =6.0.0 =6.0.0 <8.0.37-beta.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:L
- EPSS
- CVE-2023-30543: 0.38% estimated exploitation activity in the next 30 days; percentile 31.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact `chainId` may be outdated if the user changes chains as part of the connection flow. This means that the value of `chainId` returned by `useWeb3React()` may be incorrect. In an application, this means that any data derived from `chainId` could be incorrect. For example, if a swapping application derives a wrapped token contract address from the `chainId` *and* a user has changed chains as part of their connection flow the application could cause the user to send funds to the incorrect address when wrapping. This is a common approach when using other foundational libraries like `ethers`, and most users of v8 will want to upgrade past the affected versions.
Patches Patched in https://github.com/Uniswap/web3-react/pull/749. Users of web3-react@8.0.x-beta.0 should upgrade to at least: - @web3-react/coinbase-wallet@^8.0.35-beta.0 - @web3-react/eip1193@^8.0.27-beta.0 - @web3-react/metamask@^8.0.30-beta.0 -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GHSA-8pf3-6fgr-3g3g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30543 Advisory: `chainId` may be outdated if user changes chains as part of connection in @web3-react IDs: CVE-2023-30543, GHSA-8pf3-6fgr-3g3g Record: https://patchnext.com/advisories/cve-2023-30543 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @web3-react/coinbase-wallet 8.0.35-beta.0; @web3-react/walletconnect 8.0.37-beta.0; @web3-react/metamask 8.0.30-beta.0; @web3-react/eip1193 8.0.27-beta. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @web3-react/coinbase-wallet: affected >= 6.0.0, < 8.0.35-beta.0; fixed in 8.0.35-beta.0 - npm @web3-react/walletconnect: affected >= 6.0.0, < 8.0.37-beta.0; fixed in 8.0.37-beta.0 - npm @web3-react/metamask: affected >= 6.0.0, < 8.0.30-beta.0; fixed in 8.0.30-beta.0 - npm @web3-react/eip1193: affected >= 6.0.0, < 8.0.27-beta; fixed in 8.0.27-beta ## Suggested inspection (read-only) - `npm ls @web3-react/coinbase-wallet --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @web3-react/walletconnect --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @web3-react/metamask --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @web3-react/eip1193 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @web3-react/coinbase-wallet, @web3-react/walletconnect, @web3-react/metamask, @web3-react/eip1193. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8pf3-6fgr-3g3g (OSV record GHSA-8pf3-6fgr-3g3g lists affected ranges: npm @web3-react/coinbase-wallet >=6.0.0 =6.0.0 =6.0.0 =6.0.0 <8.0.37-beta.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…