Insecure header validation in slim/psr7
CVE-2023-30536GHSA-q2qj-628g-vhfw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (slim/psr7 1.6.1, 1.5.1, 1.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist slim/psr7
- Affected
- >= 1.6, < 1.6.1>= 1.5, < 1.5.1< 1.4.1
- Fixed in
- 1.4.1, 1.6.1, 1.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q2qj-628g-vhfw lists affected ranges: Packagist slim/psr7 >=1.6 =1.5 =0 <1.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2023-30536: 0.74% estimated exploitation activity in the next 30 days; percentile 54.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. An attacker that is able to control the header names that are passed to Slilm-Psr7 would be able to intentionally craft invalid messages, possibly causing application errors or invalid HTTP requests being sent out with an PSR-18 HTTP client. The latter might present a denial of service vector if a remote service’s web application firewall bans the application due to the receipt of malformed requests. Patches The issue is patched in 1.6.1, 1.5.1, and 1.4.1. Workarounds In Slim-Psr7 prior to 1.6.1, 1.5.1, and 1.4.1, validate HTTP header keys and/or values, and if using user-supplied values, filter them to strip off leading or trailing newline characters before calling withHeader(). Acknowledgments We are very grateful to and thank <a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q2qj-628g-vhfw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30536 Advisory: Insecure header validation in slim/psr7 IDs: CVE-2023-30536, GHSA-q2qj-628g-vhfw Record: https://patchnext.com/advisories/cve-2023-30536 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: slim/psr7 1.6.1, 1.5.1, 1.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist slim/psr7: affected >= 1.6, < 1.6.1; >= 1.5, < 1.5.1; < 1.4.1; fixed in 1.4.1, 1.6.1, 1.5.1 ## Suggested inspection (read-only) - Packagist slim/psr7: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on slim/psr7. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q2qj-628g-vhfw (GitHub-reviewed advisory GHSA-q2qj-628g-vhfw lists affected ranges: Packagist slim/psr7 >=1.6 =1.5 =0 <1.4.1) Commands are suggestions: review each one before running it.
Loading voting…