Apache Pulsar Incorrect Authorization vulnerability
CVE-2023-30429GHSA-g9cv-v3v4-3h8r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.pulsar:pulsar 2.11.1, 2.10.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.pulsar:pulsar
- Affected
- < 2.10.4>= 2.11.0, <= 2.11.0
- Fixed in
- 2.10.4, 2.11.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g9cv-v3v4-3h8r lists affected ranges: Maven org.apache.pulsar:pulsar >=0 =2.11.0 <=2.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2023-30429: 1.03% estimated exploitation activity in the next 30 days; percentile 63.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar. This issue affects Apache Pulsar: before 2.10.4, and 2.11.0. When a client connects to the Pulsar Function Worker via the Pulsar Proxy where the Pulsar Proxy uses mTLS authentication to authenticate with the Pulsar Function Worker, the Pulsar Function Worker incorrectly performs authorization by using the Proxy's role for authorization instead of the client's role, which can lead to privilege escalation, especially if the proxy is configured with a superuser role. The recommended mitigation for impacted users is to upgrade the Pulsar Function Worker to a patched version. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.4. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.1. 3.0 Pulsar Function Worker users are unaffected. Any users running the Pulsar Function Worker for 2.9. and earlier should upgrade to one of the above patched versions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g9cv-v3v4-3h8r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30429 Advisory: Apache Pulsar Incorrect Authorization vulnerability IDs: CVE-2023-30429, GHSA-g9cv-v3v4-3h8r Record: https://patchnext.com/advisories/cve-2023-30429 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.pulsar:pulsar 2.11.1, 2.10.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.pulsar:pulsar: affected < 2.10.4; >= 2.11.0, <= 2.11.0; fixed in 2.10.4, 2.11.1 ## Suggested inspection (read-only) - Maven org.apache.pulsar:pulsar: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.pulsar:pulsar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g9cv-v3v4-3h8r (GitHub-reviewed advisory GHSA-g9cv-v3v4-3h8r lists affected ranges: Maven org.apache.pulsar:pulsar >=0 =2.11.0 <=2.11.0) Commands are suggestions: review each one before running it.
Loading voting…