Skip to content

← Actionable
High, CVSS 8.2

Apache Pulsar Broker's Rest Producer vulnerable to Incorrect Authorization

CVE-2023-30428GHSA-j2r7-3rvw-g7gx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.pulsar:pulsar-broker 2.11.1, 2.10.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2023-30428: 0.82% estimated exploitation activity in the next 30 days; percentile 57.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar Broker's Rest Producer allows authenticated user with a custom HTTP header to produce a message to any topic using the broker's admin role. This issue affects Apache Pulsar Brokers: from 2.9.0 through 2.9.5, from 2.10.0 before 2.10.4, 2.11.0. The vulnerability is exploitable when an attacker can connect directly to the Pulsar Broker. If an attacker is connecting through the Pulsar Proxy, there is no known way to exploit this authorization vulnerability. There are two known risks for affected users. First, an attacker could produce garbage messages to any topic in the cluster. Second, an attacker could produce messages to the topic level policies topic for other tenants and influence topic settings that could lead to exfiltration and/or deletion of messages for other tenants. 2.8 Pulsar Broker users and earlier are unaffected. 2.9 Pulsar Broker users should upgrade to one of the patched versions. 2.10…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j2r7-3rvw-g7gx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-30428

Advisory: Apache Pulsar Broker's Rest Producer vulnerable to Incorrect Authorization
IDs: CVE-2023-30428, GHSA-j2r7-3rvw-g7gx
Record: https://patchnext.com/advisories/cve-2023-30428 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.pulsar:pulsar-broker 2.11.1, 2.10.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.pulsar:pulsar-broker: affected >= 2.9.0, < 2.10.4; >= 2.11.0, <= 2.11.0; fixed in 2.10.4, 2.11.1

## Suggested inspection (read-only)
- Maven org.apache.pulsar:pulsar-broker: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.pulsar:pulsar-broker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j2r7-3rvw-g7gx (GitHub-reviewed advisory GHSA-j2r7-3rvw-g7gx lists affected ranges: Maven org.apache.pulsar:pulsar-broker >=2.9.0 =2.11.0 <=2.11.0)

Commands are suggestions: review each one before running it.

Loading voting…