Dolibarr vulnerable to remote code execution via uppercase manipulation
CVE-2023-30253GHSA-9wqr-5jp4-mjmh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dolibarr/dolibarr 17.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist dolibarr/dolibarr
- Affected
- < 17.0.1
- Fixed in
- 17.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9wqr-5jp4-mjmh lists affected ranges: Packagist dolibarr/dolibarr >=0 <17.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-30253: 82.09% estimated exploitation activity in the next 30 days; percentile 99.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9wqr-5jp4-mjmh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30253 Advisory: Dolibarr vulnerable to remote code execution via uppercase manipulation IDs: CVE-2023-30253, GHSA-9wqr-5jp4-mjmh Record: https://patchnext.com/advisories/cve-2023-30253 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dolibarr/dolibarr 17.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist dolibarr/dolibarr: affected < 17.0.1; fixed in 17.0.1 ## Suggested inspection (read-only) - Packagist dolibarr/dolibarr: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dolibarr/dolibarr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9wqr-5jp4-mjmh (GitHub-reviewed advisory GHSA-9wqr-5jp4-mjmh lists affected ranges: Packagist dolibarr/dolibarr >=0 <17.0.1) Commands are suggestions: review each one before running it.
Loading voting…