nilsteampassnet/teampass vulnerable to cross-site scripting
CVE-2023-3009GHSA-h5g9-2p35-54c7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nilsteampassnet/teampass 3.0.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist nilsteampassnet/teampass
- Affected
- < 3.0.9
- Fixed in
- 3.0.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h5g9-2p35-54c7 lists affected ranges: Packagist nilsteampassnet/teampass >=0 <3.0.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-3009: 0.68% estimated exploitation activity in the next 30 days; percentile 52.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site Scripting (XSS) - Stored in GitHub repository nilsteampassnet/teampass prior to 3.0.9. This enables an attacker to inject malicious code into a shared folder, which can then be executed by other users who have access to the folder.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h5g9-2p35-54c7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-3009 Advisory: nilsteampassnet/teampass vulnerable to cross-site scripting IDs: CVE-2023-3009, GHSA-h5g9-2p35-54c7 Record: https://patchnext.com/advisories/cve-2023-3009 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nilsteampassnet/teampass 3.0.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist nilsteampassnet/teampass: affected < 3.0.9; fixed in 3.0.9 ## Suggested inspection (read-only) - Packagist nilsteampassnet/teampass: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nilsteampassnet/teampass. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h5g9-2p35-54c7 (GitHub-reviewed advisory GHSA-h5g9-2p35-54c7 lists affected ranges: Packagist nilsteampassnet/teampass >=0 <3.0.9) Commands are suggestions: review each one before running it.
Loading voting…