HTTP Multiline Header Termination
CVE-2023-29530GHSA-xv3h-4844-9h36
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (laminas/laminas-diactoros 2.25.2, 2.24.2, 2.23.1, 2.22.1, 2.21.1, 2.20.1, 2.19.1, 2.18.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist laminas/laminas-diactoros
- Affected
- < 2.18.1>= 2.19.0, <= 2.19.0>= 2.20.0, <= 2.20.0>= 2.21.0, <= 2.21.0>= 2.22.0, <= 2.22.0>= 2.23.0, <= 2.23.0>= 2.24.0, < 2.24.2>= 2.25.0, < 2.25.2
- Fixed in
- 2.22.1, 2.25.2, 2.19.1, 2.24.2, 2.23.1, 2.18.1, 2.20.1, 2.21.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xv3h-4844-9h36 lists affected ranges: Packagist laminas/laminas-diactoros >=0 =2.19.0 =2.20.0 =2.21.0 =2.22.0 =2.23.0 =2.24.0 =2.25.0 <2.25.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-29530: 0.97% estimated exploitation activity in the next 30 days; percentile 61.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Affected versions of Laminas Diactoros accepted a single line feed (LF / \n ) character at the end of a header name. When serializing such a header name containing a line-feed into the on-the-wire representation of a HTTP/1.x message, the resulting message would be syntactically invalid, due to the header line being terminated too early. An attacker that is able to control the header names that are passed to Laminas Diactoros would be able to intentionally craft invalid messages, possibly causing application errors or invalid HTTP requests being sent out with an PSR-18 HTTP client. The latter might present a denial of service vector if a remote service’s web application firewall bans the application due to the receipt of malformed requests. Patches The problem has been patched in the following versions: - 2.18.1 - 2.19.1 - 2.20.1 - 2.21.1 - 2.22.1 - 2.23.1 - 2.24.2 - 2.25.2 Workarounds Validate HTTP header keys and/or values, and if using user-supplied values, filter them to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xv3h-4844-9h36
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-29530 Advisory: HTTP Multiline Header Termination IDs: CVE-2023-29530, GHSA-xv3h-4844-9h36 Record: https://patchnext.com/advisories/cve-2023-29530 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: laminas/laminas-diactoros 2.25.2, 2.24.2, 2.23.1, 2.22.1, 2.21.1, 2.20.1, 2.19.1, 2.18.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist laminas/laminas-diactoros: affected < 2.18.1; >= 2.19.0, <= 2.19.0; >= 2.20.0, <= 2.20.0; >= 2.21.0, <= 2.21.0; >= 2.22.0, <= 2.22.0; >= 2.23.0, <= 2.23.0; >= 2.24.0, < 2.24.2; >= 2.25.0, < 2.25.2; fixed in 2.22.1, 2.25.2, 2.19.1, 2.24.2, 2.23.1, 2.18.1, 2.20.1, 2.21.1 ## Suggested inspection (read-only) - Packagist laminas/laminas-diactoros: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on laminas/laminas-diactoros. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xv3h-4844-9h36 (GitHub-reviewed advisory GHSA-xv3h-4844-9h36 lists affected ranges: Packagist laminas/laminas-diactoros >=0 =2.19.0 =2.20.0 =2.21.0 =2.22.0 =2.23.0 =2.24.0 =2.25.0 <2.25.2) Commands are suggestions: review each one before running it.
Loading voting…