Skip to content

← Actionable
Critical, CVSS 9.0

Cross-site Scripting in org.xwiki.commons:xwiki-commons-xml

CVE-2023-29528GHSA-x37v-36wv-6v6h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.commons:xwiki-commons-xml 14.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-29528: 1.28% estimated exploitation activity in the next 30 days; percentile 69.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The "restricted" mode of the HTML cleaner in XWiki, introduced in version 4.2-milestone-1 and massively improved in version 14.6-rc-1, allowed the injection of arbitrary HTML code and thus cross-site scripting via invalid HTML comments. As a consequence, any code relying on this "restricted" mode for security is vulnerable to JavaScript injection ("cross-site scripting"/XSS). An example are anonymous comments in XWiki where the HTML macro filters HTML using restricted mode: When a privileged user with programming rights visits such a comment in XWiki, the malicious JavaScript code is executed in the context of the user session. This allows server-side code execution with programming rights, impacting the confidentiality, integrity and availability of the XWiki instance. Note that while all versions since 4.2-milestone-1 should be vulnerable, only starting with version 14.6-rc-1 the HTML comment is necessary for the attack to succeed due to another vulnerability that has been…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x37v-36wv-6v6h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-29528

Advisory: Cross-site Scripting in org.xwiki.commons:xwiki-commons-xml
IDs: CVE-2023-29528, GHSA-x37v-36wv-6v6h
Record: https://patchnext.com/advisories/cve-2023-29528 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.commons:xwiki-commons-xml 14.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.commons:xwiki-commons-xml: affected >= 4.2-milestone-1, < 14.10; fixed in 14.10

## Suggested inspection (read-only)
- Maven org.xwiki.commons:xwiki-commons-xml: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.commons:xwiki-commons-xml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x37v-36wv-6v6h (GitHub-reviewed advisory GHSA-x37v-36wv-6v6h lists affected ranges: Maven org.xwiki.commons:xwiki-commons-xml >=4.2-milestone-1 <14.10)

Commands are suggestions: review each one before running it.

Loading voting…