Skip to content

← Actionable
Critical, CVSS 9.9

XWiki Platform vulnerable to privilege escalation from view right on XWiki.Notifications.Code.LegacyNotificationAdministration

CVE-2023-29525GHSA-jgg7-w2rj-58cj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-distribution-war 14.6-rc-1, 14.4.8, 13.10.11; org.xwiki.platform:xwiki-platform-legacy-events-hibernate-ui 14.10.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-jgg7-w2rj-58cj lists affected ranges: Maven org.xwiki.platform:xwiki-platform-distribution-war >=12.6.1 =14.0-rc-1 =14.5 =14.6-rc-1 <14.10.3

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-29525: 77.75% estimated exploitation activity in the next 30 days; percentile 99.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Steps to reproduce: Open <xwiki-host/xwiki/bin/view/XWiki/Notifications/Code/LegacyNotificationAdministration?since=%7B%7B%2Fhtml%7D%7D+%7B%7Basync+async%3D%22true%22+cached%3D%22false%22+context%3D%22doc.reference%22%7D%7D%7B%7Bgroovy%7D%7Dprintln%28%22Hello+%22+%2B+%22from+groovy%21%22%29%7B%7B%2Fgroovy%7D%7D%7B%7B%2Fasync%7D%7D, where <xwiki-host is the URL of your XWiki installation. This demonstrates an XWiki syntax injection attack via the since-parameter, allowing privilege escalation from view to programming rights. Patches The vulnerability has been patched in XWiki 15.0-rc-1, 14.10.3, 14.4.8 and 14.10.3. Workarounds For versions = 14.6-rc-1 the workaround is to modify the page XWiki.Notifications.Code.LegacyNotificationAdministration to add the missing escaping, as described on https://github.com/xwiki/xwiki-platform/commit/8e7c7f90f2ddaf067cb5b83b181af41513028754#diff-4e13f4ee4a42938bf1201b7ee71ca32edeacba22559daf0bcb89d534e0225949R70 For versions < 14.6-rc-1 the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jgg7-w2rj-58cj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-29525

Advisory: XWiki Platform vulnerable to privilege escalation from view right on XWiki.Notifications.Code.LegacyNotificationAdministration
IDs: CVE-2023-29525, GHSA-jgg7-w2rj-58cj
Record: https://patchnext.com/advisories/cve-2023-29525 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-distribution-war 14.6-rc-1, 14.4.8, 13.10.11; org.xwiki.platform:xwiki-platform-legacy-events-hibernate-ui 14.10.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-distribution-war: affected >= 12.6.1, < 13.10.11; >= 14.0-rc-1, < 14.4.8; >= 14.5, < 14.6-rc-1; fixed in 14.6-rc-1, 13.10.11, 14.4.8
- Maven org.xwiki.platform:xwiki-platform-legacy-events-hibernate-ui: affected >= 14.6-rc-1, < 14.10.3; fixed in 14.10.3

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-distribution-war: check the installed version with your package manager.
- Maven org.xwiki.platform:xwiki-platform-legacy-events-hibernate-ui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-distribution-war, org.xwiki.platform:xwiki-platform-legacy-events-hibernate-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jgg7-w2rj-58cj (GitHub-reviewed advisory GHSA-jgg7-w2rj-58cj lists affected ranges: Maven org.xwiki.platform:xwiki-platform-distribution-war >=12.6.1 =14.0-rc-1 =14.5 =14.6-rc-1 <14.10.3)

Commands are suggestions: review each one before running it.

Loading voting…