Skip to content

← Actionable
Medium, CVSS 4.3

XWiki Platform vulnerable to page render failure due to broken translations

CVE-2023-29520GHSA-9jq5-xwqw-q8j3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-localization-source-wiki 14.10.1, 14.4.8, 13.10.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-9jq5-xwqw-q8j3 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-localization-source-wiki >=4.3-milestone-2 =14.0-rc-1 =14.5 <14.10.1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2023-29520: 0.53% estimated exploitation activity in the next 30 days; percentile 44.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact It's possible to break many translations coming from wiki pages by creating a corrupted document containing a translation object. Patches The vulnerability has been patched in XWiki 15.0-rc-1, 14.10.1, 14.4.8, and 13.10.11. Workarounds There is no other workaround other than fixing any way to create a document that fail to load. References https://jira.xwiki.org/browse/XWIKI-20460 For more information If you have any questions or comments about this advisory: Open an issue in Jira XWiki.org Email us at Security Mailing List

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9jq5-xwqw-q8j3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-29520

Advisory: XWiki Platform vulnerable to page render failure due to broken translations
IDs: CVE-2023-29520, GHSA-9jq5-xwqw-q8j3
Record: https://patchnext.com/advisories/cve-2023-29520 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-localization-source-wiki 14.10.1, 14.4.8, 13.10.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-localization-source-wiki: affected >= 4.3-milestone-2, < 13.10.11; >= 14.0-rc-1, < 14.4.8; >= 14.5, < 14.10.1; fixed in 13.10.11, 14.10.1, 14.4.8

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-localization-source-wiki: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-localization-source-wiki.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9jq5-xwqw-q8j3 (GitHub-reviewed advisory GHSA-9jq5-xwqw-q8j3 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-localization-source-wiki >=4.3-milestone-2 =14.0-rc-1 =14.5 <14.10.1)

Commands are suggestions: review each one before running it.

Loading voting…