Skip to content

← Actionable
High, CVSS 8.8

org.xwiki.platform:xwiki-platform-attachment-ui vulnerable to Code Injection

CVE-2023-29519GHSA-3hjg-cghv-22ww

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-attachment-ui 14.10.2, 14.4.8, 13.10.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-3hjg-cghv-22ww lists affected ranges: Maven org.xwiki.platform:xwiki-platform-attachment-ui >=3.0-rc-1 =14.0-rc-1 =14.5 <14.10.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-29519: 1.94% estimated exploitation activity in the next 30 days; percentile 80.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A registered user can perform remote code execution leading to privilege escalation by injecting the proper code in the "property" field of an attachment selector, as a gadget of their own dashboard. Note that the vulnerability does not impact comments of a wiki. Patches The vulnerability has been patched in XWiki 13.10.11, 14.4.8, 14.10.2, 15.0-rc-1. Workarounds The problem can be worked around by applying following changes directly in XWiki.AttachmentSelector page: https://github.com/xwiki/xwiki-platform/commit/5e8725b4272cd3e5be09d3ca84273be2da6869c1. References https://jira.xwiki.org/browse/XWIKI-20364 https://github.com/xwiki/xwiki-platform/commit/5e8725b4272cd3e5be09d3ca84273be2da6869c1 For more information If you have any questions or comments about this advisory: Open an issue in Jira XWiki.org Email us at Security Mailing List

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3hjg-cghv-22ww

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-29519

Advisory: org.xwiki.platform:xwiki-platform-attachment-ui vulnerable to Code Injection
IDs: CVE-2023-29519, GHSA-3hjg-cghv-22ww
Record: https://patchnext.com/advisories/cve-2023-29519 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-attachment-ui 14.10.2, 14.4.8, 13.10.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-attachment-ui: affected >= 3.0-rc-1, < 13.10.11; >= 14.0-rc-1, < 14.4.8; >= 14.5, < 14.10.2; fixed in 13.10.11, 14.10.2, 14.4.8

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-attachment-ui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-attachment-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3hjg-cghv-22ww (GitHub-reviewed advisory GHSA-3hjg-cghv-22ww lists affected ranges: Maven org.xwiki.platform:xwiki-platform-attachment-ui >=3.0-rc-1 =14.0-rc-1 =14.5 <14.10.2)

Commands are suggestions: review each one before running it.

Loading voting…