org.xwiki.platform:xwiki-platform-oldcore makes Incorrect Use of Privileged APIs with DocumentAuthors
CVE-2023-29507GHSA-pwfv-3cvg-9m4c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 14.10, 14.4.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-oldcore
- Affected
- >= 14.5, < 14.10>= 14.4.1, < 14.4.7
- Fixed in
- 14.10, 14.4.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pwfv-3cvg-9m4c lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=14.5 =14.4.1 <14.4.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-29507: 0.90% estimated exploitation activity in the next 30 days; percentile 59.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Document script API returns directly a DocumentAuthors allowing to set any authors to the document, which in consequence can allow subsequent executions of scripts since this author is used for checking rights. Example of such attack: Patches The problem has been patched in XWiki 14.10 and 14.4.7 by returning a safe script API. Workarounds There no easy workaround apart of upgrading. References https://jira.xwiki.org/browse/XWIKI-20380 https://github.com/xwiki/xwiki-platform/commit/905cdd7c421dbf8c565557cdc773ab1aa9028f83 For more information If you have any questions or comments about this advisory: Open an issue in Jira Email us at security ML
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pwfv-3cvg-9m4c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-29507 Advisory: org.xwiki.platform:xwiki-platform-oldcore makes Incorrect Use of Privileged APIs with DocumentAuthors IDs: CVE-2023-29507, GHSA-pwfv-3cvg-9m4c Record: https://patchnext.com/advisories/cve-2023-29507 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 14.10, 14.4.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 14.5, < 14.10; >= 14.4.1, < 14.4.7; fixed in 14.10, 14.4.7 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pwfv-3cvg-9m4c (GitHub-reviewed advisory GHSA-pwfv-3cvg-9m4c lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=14.5 =14.4.1 <14.4.7) Commands are suggestions: review each one before running it.
Loading voting…