Skip to content

← Actionable
Medium, CVSS 5.4

org.xwiki.platform:xwiki-platform-security-authentication-default XSS with authenticate endpoints

CVE-2023-29506GHSA-jjm5-5v9v-7hx2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-security-authentication-default 14.10, 14.4.7, 13.10.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-jjm5-5v9v-7hx2 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-security-authentication-default >=13.10.8 =14.4.3 =14.6 <14.10

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2023-29506: 1.72% estimated exploitation activity in the next 30 days; percentile 77.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact It was possible to inject some code using the URL of authenticate endpoints, e.g.: This vulnerability was present in recent versions of XWiki: - 13.10.8+ - 14.4.3+ - 14.6+ Patches This problem has been patched on XWiki 13.10.11, 14.4.7 and 14.10. Workarounds There is no easy workaround except to upgrade. References - https://jira.xwiki.org/browse/XWIKI-20335 - https://github.com/xwiki/xwiki-platform/commit/1943ea26c967ef868fb5f67c487d98d97cba0380 For more information If you have any questions or comments about this advisory: Open an issue in Jira Email us at security mailing-list

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jjm5-5v9v-7hx2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-29506

Advisory: org.xwiki.platform:xwiki-platform-security-authentication-default XSS with authenticate endpoints
IDs: CVE-2023-29506, GHSA-jjm5-5v9v-7hx2
Record: https://patchnext.com/advisories/cve-2023-29506 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-security-authentication-default 14.10, 14.4.7, 13.10.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-security-authentication-default: affected >= 13.10.8, < 13.10.11; >= 14.4.3, < 14.4.7; >= 14.6, < 14.10; fixed in 14.10, 14.4.7, 13.10.11

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-security-authentication-default: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-security-authentication-default.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jjm5-5v9v-7hx2 (GitHub-reviewed advisory GHSA-jjm5-5v9v-7hx2 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-security-authentication-default >=13.10.8 =14.4.3 =14.6 <14.10)

Commands are suggestions: review each one before running it.

Loading voting…