Potential DoS via the Tudoor mechanism in eventlet and dnspython
CVE-2023-29483GHSA-3rq5-2g8h-59hc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dnspython 2.6.1; eventlet 0.35.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3rq5-2g8h-59hc lists affected ranges: PyPI eventlet >=0 =0 <2.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3rq5-2g8h-59hc lists affected ranges: PyPI eventlet >=0 =0 <2.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-29483: 1.86% estimated exploitation activity in the next 30 days; percentile 79.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
eventlet before 0.35.2, as used in dnspython before 2.6.0, allows remote attackers to interfere with DNS name resolution by quickly sending an invalid packet from the expected IP address and source port, aka a "TuDoor" attack. In other words, dnspython does not have the preferred behavior in which the DNS name resolution algorithm would proceed, within the full time window, in order to wait for a valid packet. NOTE: dnspython 2.6.0 is unusable for a different reason that was addressed in 2.6.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3rq5-2g8h-59hc
- Revision 1 · created ·
Published from osv record GHSA-3rq5-2g8h-59hc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-29483 Advisory: Potential DoS via the Tudoor mechanism in eventlet and dnspython IDs: CVE-2023-29483, GHSA-3rq5-2g8h-59hc Record: https://patchnext.com/advisories/cve-2023-29483 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dnspython 2.6.1; eventlet 0.35.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI dnspython: affected < 2.6.1; fixed in 2.6.1 - PyPI eventlet: affected < 0.35.2; fixed in 0.35.2 ## Suggested inspection (read-only) - `python -m pip show dnspython`: prints the installed version. Run with the environment that serves production active. - `python -m pip show eventlet`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dnspython, eventlet. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3rq5-2g8h-59hc (OSV record GHSA-3rq5-2g8h-59hc lists affected ranges: PyPI eventlet >=0 =0 <2.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-3rq5-2g8h-59hc (GitHub-reviewed advisory GHSA-3rq5-2g8h-59hc lists affected ranges: PyPI eventlet >=0 =0 <2.6.1) Commands are suggestions: review each one before running it.
Loading voting…