NuGet Client Remote Code Execution Vulnerability
CVE-2023-29337GHSA-6qmf-mmc7-6c2p
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet nuget.commands
- Affected
- >= 6.2.0, < 6.2.4>= 6.3.0, < 6.3.3>= 6.4.0, < 6.4.2>= 6.5.0, <= 6.5.0>= 6.6.0, <= 6.6.0>= 6.0.0, < 6.0.5>= 4.6.0, < 5.11.5
- Fixed in
- 6.4.2, 6.3.3, 6.2.4, 6.0.5, 6.5.1, 5.11.5, 6.6.1
NuGet nuget.commandline
- Affected
- >= 6.2.0, < 6.2.4>= 6.3.0, < 6.3.3>= 6.4.0, < 6.4.2>= 6.5.0, <= 6.5.0>= 6.6.0, <= 6.6.0>= 6.0.0, < 6.0.5>= 4.6.0, < 5.11.5
- Fixed in
- 6.4.2, 6.3.3, 6.2.4, 6.0.5, 6.5.1, 5.11.5, 6.6.1
NuGet nuget.packagemanagement
- Affected
- >= 6.2.0, < 6.2.4>= 6.3.0, < 6.3.3>= 6.4.0, < 6.4.2>= 6.5.0, <= 6.5.0>= 6.6.0, <= 6.6.0>= 6.0.0, < 6.0.5>= 4.6.0, < 5.11.5
- Fixed in
- 6.4.2, 6.3.3, 6.2.4, 6.0.5, 6.5.1, 5.11.5, 6.6.1
NuGet nuget.common
- Affected
- >= 6.2.0, < 6.2.4>= 6.3.0, < 6.3.3>= 6.4.0, < 6.4.2>= 6.5.0, <= 6.5.0>= 6.6.0, <= 6.6.0>= 6.0.0, < 6.0.5>= 4.6.0, < 5.11.5
- Fixed in
- 6.4.2, 6.3.3, 6.2.4, 6.0.5, 6.5.1, 5.11.5, 6.6.1
NuGet microsoft.build.nugetsdkresolver
- Affected
- >= 5.9.0-rc.7122, <= 5.9.0-rc.7122>= 5.10.0-rc.7240, <= 5.10.0-rc.7240>= 5.11.0-rc.10, <= 5.11.0-rc.10
- Fixed in
- no fixed version recorded
NuGet nuget.protocol
- Affected
- >= 6.2.0, < 6.2.4>= 6.3.0, < 6.3.3>= 6.4.0, < 6.4.2>= 6.5.0, <= 6.5.0>= 6.6.0, <= 6.6.0>= 6.0.0, < 6.0.5>= 4.7.0, < 5.11.5
- Fixed in
- 6.4.2, 6.3.3, 6.2.4, 6.0.5, 6.5.1, 5.11.5, 6.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6qmf-mmc7-6c2p lists affected ranges: NuGet microsoft.build.nugetsdkresolver >=5.9.0-rc.7122 =5.10.0-rc.7240 =5.11.0-rc.10 =6.2.0 =6.3.0 =6.4.0 =6.5.0 =6.6.0 =6.0.0 =4.6.0 =6.2.0 =6.3.0 =6.4.0 =6.5.0 =6.6.0 =6.0.0 =4.6.0 <5.11.5; NuGet…
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-29337: 1.15% estimated exploitation activity in the next 30 days; percentile 66.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Microsoft is releasing this security advisory to provide information about a vulnerability in .NET and NuGet on Linux. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A vulnerability exists in .NET 6.0, .NET 7.0 and NuGet(nuget.exe, NuGet.Protocol, NuGet.Common, NuGet.CommandLine, NuGet.Commands, Microsoft.Build.NuGetSdkResolver, NuGet.PackageManagement) where a potential race condition that can lead to a symlink attack on Linux. Non-Linux platforms are not affected. Affected software This issue only affects Linux systems. NuGet & NuGet Packages - Any NuGet.exe, NuGet.Protocol, NuGet.Common, NuGet.CommandLine, NuGet.Commands, Microsoft.Build.NuGetSdkResolver, NuGet.PackageManagement 6.6.0 version or earlier. - Any NuGet.exe, NuGet.Protocol, NuGet.Common, NuGet.CommandLine, NuGet.Commands, Microsoft.Build.NuGetSdkResolver, NuGet.PackageManagement 6.5.0 version or earlier. - Any NuGet.exe,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6qmf-mmc7-6c2p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-29337 Advisory: NuGet Client Remote Code Execution Vulnerability IDs: CVE-2023-29337, GHSA-6qmf-mmc7-6c2p Record: https://patchnext.com/advisories/cve-2023-29337 (revision 1, source checked 26 Oct 2026, 17:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: nuget.commands 6.6.1, 6.5.1, 6.4.2, 6.3.3, 6.2.4, 6.0.5, 5.11.5; nuget.commandline 6.6.1, 6.5.1, 6.4.2, 6.3.3, 6.2.4, 6.0.5, 5.11.5; nuget.packagemanagement 6.6.1, 6.5.1, 6.4.2, 6.3.3, 6.2.4, 6.0.5, 5.11.5; nuget.common 6.6.1, 6.5.1, 6.4.2, 6.3.3, 6.2.4, 6.0.5, 5.11.5; nuget.protocol 6.6.1, 6.5.1, 6.4.2, 6.3.3, 6.2.4, 6.0.5, 5.11.5. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet nuget.commands: affected >= 6.2.0, < 6.2.4; >= 6.3.0, < 6.3.3; >= 6.4.0, < 6.4.2; >= 6.5.0, <= 6.5.0; >= 6.6.0, <= 6.6.0; >= 6.0.0, < 6.0.5; >= 4.6.0, < 5.11.5; fixed in 6.4.2, 6.3.3, 6.2.4, 6.0.5, 6.5.1, 5.11.5, 6.6.1 - NuGet nuget.commandline: affected >= 6.2.0, < 6.2.4; >= 6.3.0, < 6.3.3; >= 6.4.0, < 6.4.2; >= 6.5.0, <= 6.5.0; >= 6.6.0, <= 6.6.0; >= 6.0.0, < 6.0.5; >= 4.6.0, < 5.11.5; fixed in 6.4.2, 6.3.3, 6.2.4, 6.0.5, 6.5.1, 5.11.5, 6.6.1 - NuGet nuget.packagemanagement: affected >= 6.2.0, < 6.2.4; >= 6.3.0, < 6.3.3; >= 6.4.0, < 6.4.2; >= 6.5.0, <= 6.5.0; >= 6.6.0, <= 6.6.0; >= 6.0.0, < 6.0.5; >= 4.6.0, < 5.11.5; fixed in 6.4.2, 6.3.3, 6.2.4, 6.0.5, 6.5.1, 5.11.5, 6.6.1 - NuGet nuget.common: affected >= 6.2.0, < 6.2.4; >= 6.3.0, < 6.3.3; >= 6.4.0, < 6.4.2; >= 6.5.0, <= 6.5.0; >= 6.6.0, <= 6.6.0; >= 6.0.0, < 6.0.5; >= 4.6.0, < 5.11.5; fixed in 6.4.2, 6.3.3, 6.2.4, 6.0.5, 6.5.1, 5.11.5, 6.6.1 - NuGet microsoft.build.nugetsdkresolver: affected >= 5.9.0-rc.7122, <= 5.9.0-rc.7122; >= 5.10.0-rc.7240, <= 5.10.0-rc.7240; >= 5.11.0-rc.10, <= 5.11.0-rc.10 - NuGet nuget.protocol: affected >= 6.2.0, < 6.2.4; >= 6.3.0, < 6.3.3; >= 6.4.0, < 6.4.2; >= 6.5.0, <= 6.5.0; >= 6.6.0, <= 6.6.0; >= 6.0.0, < 6.0.5; >= 4.7.0, < 5.11.5; fixed in 6.4.2, 6.3.3, 6.2.4, 6.0.5, 6.5.1, 5.11.5, 6.6.1 ## Suggested inspection (read-only) - NuGet nuget.commands: check the installed version with your package manager. - NuGet nuget.commandline: check the installed version with your package manager. - NuGet nuget.packagemanagement: check the installed version with your package manager. - NuGet nuget.common: check the installed version with your package manager. - NuGet microsoft.build.nugetsdkresolver: check the installed version with your package manager. - NuGet nuget.protocol: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nuget.commands, nuget.commandline, nuget.packagemanagement, nuget.common, microsoft.build.nugetsdkresolver, nuget.protocol. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6qmf-mmc7-6c2p (GitHub-reviewed advisory GHSA-6qmf-mmc7-6c2p lists affected ranges: NuGet microsoft.build.nugetsdkresolver >=5.9.0-rc.7122 =5.10.0-rc.7240 =5.11.0-rc.10 =6.2.0 =6.3.0 =6.4.0 =6.5.0 =6.6.0 =6.0.0 =4.6.0 =6.2.0 =6.3.0 =6.4.0 =6.5.0 =6.6.0 =6.0.0 =4.6.0 <5.11.5; NuGet…) Commands are suggestions: review each one before running it.
Loading voting…