Magento Open Source allows Improper Neutralization of Special Elements Used
CVE-2023-29297GHSA-gfmm-ww6f-5mm5
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/project-community-edition
- Affected
- <= 2.0.2
- Fixed in
- no fixed version recorded
Packagist magento/community-edition
- Affected
- >= 2.4.6, <= 2.4.6>= 2.4.5, <= 2.4.5>= 2.4.4, <= 2.4.4>= 2.4.5-p1, < 2.4.5-p3>= 2.4.4-p1, < 2.4.4-p4
- Fixed in
- 2.4.4-p4, 2.4.5-p3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gfmm-ww6f-5mm5 lists affected ranges: Packagist magento/community-edition >=2.4.6 =2.4.5 =2.4.4 =2.4.5-p1 =2.4.4-p1 =0 <=2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:U · score source
- EPSS
- CVE-2023-29297: 1.35% estimated exploitation activity in the next 30 days; percentile 71.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Adobe Commerce versions 2.4.6 (and earlier), 2.4.5-p2 (and earlier) and 2.4.4-p3 (and earlier) are affected by a Improper Neutralization of Special Elements Used in a Template Engine vulnerability that could lead to arbitrary code execution by an admin-privilege authenticated attacker. Exploitation of this issue does not require user interaction.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gfmm-ww6f-5mm5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-29297 Advisory: Magento Open Source allows Improper Neutralization of Special Elements Used IDs: CVE-2023-29297, GHSA-gfmm-ww6f-5mm5 Record: https://patchnext.com/advisories/cve-2023-29297 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: magento/community-edition 2.4.5-p3, 2.4.4-p4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/project-community-edition: affected <= 2.0.2 - Packagist magento/community-edition: affected >= 2.4.6, <= 2.4.6; >= 2.4.5, <= 2.4.5; >= 2.4.4, <= 2.4.4; >= 2.4.5-p1, < 2.4.5-p3; >= 2.4.4-p1, < 2.4.4-p4; fixed in 2.4.4-p4, 2.4.5-p3 ## Suggested inspection (read-only) - Packagist magento/project-community-edition: check the installed version with your package manager. - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/project-community-edition, magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gfmm-ww6f-5mm5 (GitHub-reviewed advisory GHSA-gfmm-ww6f-5mm5 lists affected ranges: Packagist magento/community-edition >=2.4.6 =2.4.5 =2.4.4 =2.4.5-p1 =2.4.4-p1 =0 <=2.0.2) Commands are suggestions: review each one before running it.
Loading voting…