xwiki.platform:xwiki-platform-panels-ui Eval Injection vulnerability
CVE-2023-29212GHSA-c5f4-p5wv-2475
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-panels-ui 14.10, 14.4.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-panels-ui
- Affected
- >= 14.0-rc-1, < 14.4.7>= 14.5, < 14.10
- Fixed in
- 14.10, 14.4.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c5f4-p5wv-2475 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-panels-ui >=14.0-rc-1 =14.5 <14.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-29212: 1.19% estimated exploitation activity in the next 30 days; percentile 68.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Any user with edit rights can execute arbitrary Groovy, Python or Velocity code in XWiki leading to full access to the XWiki installation. The root cause is improper escaping of the included pages in the included documents edit panel. A proof of concept exploit is to edit a document and add the following code before saving. expected The right had side panels contain: actual The right had side panels contain: Patches The problem has been patched on XWiki 14.4.7, and 14.10. Workarounds The issue can be fixed manually applying this patch. References - https://github.com/xwiki/xwiki-platform/commit/22f249a0eb9f2a64214628217e812a994419b69f#diff-a51a252f0190274464027342b4e3eafc4ae32de4d9c17ef166e54fc5454c5689R214-R217 - https://jira.xwiki.org/browse/XWIKI-20293 For more information If you have any questions or comments about this advisory: Open an issue in Jira XWiki.org Email us at Security Mailing List
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c5f4-p5wv-2475
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-29212 Advisory: xwiki.platform:xwiki-platform-panels-ui Eval Injection vulnerability IDs: CVE-2023-29212, GHSA-c5f4-p5wv-2475 Record: https://patchnext.com/advisories/cve-2023-29212 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-panels-ui 14.10, 14.4.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-panels-ui: affected >= 14.0-rc-1, < 14.4.7; >= 14.5, < 14.10; fixed in 14.10, 14.4.7 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-panels-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-panels-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c5f4-p5wv-2475 (GitHub-reviewed advisory GHSA-c5f4-p5wv-2475 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-panels-ui >=14.0-rc-1 =14.5 <14.10) Commands are suggestions: review each one before running it.
Loading voting…