Skip to content

← Actionable
High, CVSS 7.5

org.xwiki.platform:xwiki-platform-oldcore vulnerable to data leak through deleted documents

CVE-2023-29208GHSA-4f8g-fq6x-jqrr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 14.10, 14.4.7, 13.10.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-4f8g-fq6x-jqrr lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=1.2-milestone-1 =14.0-rc-1 =14.5 <14.10

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-29208: 0.93% estimated exploitation activity in the next 30 days; percentile 60.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Rights added to a document are not taken into account for viewing it once it's deleted. Note that this vulnerability only impact deleted documents that where containing view rights: the view rights provided on a space of a deleted document are properly checked. Patches The problem has been patched in XWiki 14.10 by checking the rights of current user: only admin and deleter of the document are allowed to view it. Workarounds There is no workaround for this vulnerability other than upgrading. References Jira ticket: https://jira.xwiki.org/browse/XWIKI-16285 Commit: https://github.com/xwiki/xwiki-platform/commit/d9e947559077e947315bf700c5703dfc7dd8a8d7 For more information If you have any questions or comments about this advisory: Open an issue in Jira Email us at security ML

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4f8g-fq6x-jqrr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-29208

Advisory: org.xwiki.platform:xwiki-platform-oldcore vulnerable to data leak through deleted documents
IDs: CVE-2023-29208, GHSA-4f8g-fq6x-jqrr
Record: https://patchnext.com/advisories/cve-2023-29208 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 14.10, 14.4.7, 13.10.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 1.2-milestone-1, < 13.10.11; >= 14.0-rc-1, < 14.4.7; >= 14.5, < 14.10; fixed in 14.10, 14.4.7, 13.10.11

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4f8g-fq6x-jqrr (GitHub-reviewed advisory GHSA-4f8g-fq6x-jqrr lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=1.2-milestone-1 =14.0-rc-1 =14.5 <14.10)

Commands are suggestions: review each one before running it.

Loading voting…