vm2 Sandbox Escape vulnerability
CVE-2023-29199GHSA-xj72-wvfv-8985
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.9.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- < 3.9.16
- Fixed in
- 3.9.16
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xj72-wvfv-8985 lists affected ranges: npm vm2 >=0 <3.9.16 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xj72-wvfv-8985 lists affected ranges: npm vm2 >=0 <3.9.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-29199: 3.85% estimated exploitation activity in the next 30 days; percentile 90.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There exists a vulnerability in source code transformer (exception sanitization logic) of vm2 for versions up to 3.9.15, allowing attackers to bypass handleException() and leak unsanitized host exceptions which can be used to escape the sandbox and run arbitrary code in host context. Impact A threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. Patches This vulnerability was patched in the release of version 3.9.16 of vm2. Workarounds None. References Github Issue - https://github.com/patriksimek/vm2/issues/516 PoC - https://gist.github.com/leesh3288/f05730165799bf56d70391f3d9ea187c For more information If you have any questions or comments about this advisory: - Open an issue in VM2 Thanks to Xion (SeungHyun Lee) of KAIST Hacking Lab for disclosing this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xj72-wvfv-8985
- Revision 1 · created ·
Published from osv record GHSA-xj72-wvfv-8985
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-29199 Advisory: vm2 Sandbox Escape vulnerability IDs: CVE-2023-29199, GHSA-xj72-wvfv-8985 Record: https://patchnext.com/advisories/cve-2023-29199 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.9.16. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected < 3.9.16; fixed in 3.9.16 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xj72-wvfv-8985 (OSV record GHSA-xj72-wvfv-8985 lists affected ranges: npm vm2 >=0 <3.9.16 (fixed)) - Verified: https://github.com/advisories/GHSA-xj72-wvfv-8985 (GitHub-reviewed advisory GHSA-xj72-wvfv-8985 lists affected ranges: npm vm2 >=0 <3.9.16) Commands are suggestions: review each one before running it.
Loading voting…