Skip to content

← Actionable
Medium, CVSS 6.0amended

Electron context isolation bypass via nested unserializable return value

CVE-2023-29198GHSA-p7v2-p9m8-qqg7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 25.0.0-alpha.2, 24.0.1, 23.2.3, 22.3.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm electron

    Affected
    < 22.3.6>= 23.0.0-alpha.1, < 23.2.3>= 24.0.0-alpha.1, < 24.0.1>= 25.0.0-alpha.1, < 25.0.0-alpha.2
    Fixed in
    24.0.1, 23.2.3, 25.0.0-alpha.2, 22.3.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:L
EPSS
  • CVE-2023-29198: 0.59% estimated exploitation activity in the next 30 days; percentile 48.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Apps using contextIsolation and contextBridge are affected. This is a context isolation bypass, meaning that code running in the main world context in the renderer can reach into the isolated Electron context and perform privileged actions. Workarounds This issue is exploitable under either of two conditions: If an API exposed to the main world via contextBridge can return an object or array that contains a JS object which cannot be serialized, for instance, a canvas rendering context. This would normally result in an exception being thrown Error: object could not be cloned. If an API exposed to the main world via contextBridge has a return value that throws a user-generated exception while being sent over the bridge, for instance a dynamic getter property on an object that throws an error when being computed. The app side workaround is to ensure that such a case is not possible. Ensure all values returned from a function exposed over the context bridge are supported and that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p7v2-p9m8-qqg7

  2. Revision 1 · created ·

    Published from osv record GHSA-p7v2-p9m8-qqg7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-29198

Advisory: Electron context isolation bypass via nested unserializable return value
IDs: CVE-2023-29198, GHSA-p7v2-p9m8-qqg7
Record: https://patchnext.com/advisories/cve-2023-29198 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: electron 25.0.0-alpha.2, 24.0.1, 23.2.3, 22.3.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm electron: affected < 22.3.6; >= 23.0.0-alpha.1, < 23.2.3; >= 24.0.0-alpha.1, < 24.0.1; >= 25.0.0-alpha.1, < 25.0.0-alpha.2; fixed in 24.0.1, 23.2.3, 25.0.0-alpha.2, 22.3.6

## Suggested inspection (read-only)
- `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electron.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p7v2-p9m8-qqg7 (OSV record GHSA-p7v2-p9m8-qqg7 lists affected ranges: npm electron >=0 =23.0.0-alpha.1 =24.0.0-alpha.1 =25.0.0-alpha.1 <25.0.0-alpha.2 (fixed))
- Verified: https://github.com/advisories/GHSA-p7v2-p9m8-qqg7 (GitHub-reviewed advisory GHSA-p7v2-p9m8-qqg7 lists affected ranges: npm electron >=0 =23.0.0-alpha.1 =24.0.0-alpha.1 =25.0.0-alpha.1 <25.0.0-alpha.2)

Commands are suggestions: review each one before running it.

Loading voting…