Skip to content

← Actionable
Medium, CVSS 6.5amended

CSRF token fixation in fastify-passport

CVE-2023-29020GHSA-2ccf-ffrj-m4qw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/passport 2.3.0, 1.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2023-29020: 0.38% estimated exploitation activity in the next 30 days; percentile 32.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The CSRF protection enforced by the @fastify/csrf-protection library, when combined with @fastify/passport, can be bypassed by network and same-site attackers. Details fastify/csrf-protection implements the synchronizer token pattern (using plugins @fastify/session and @fastify/secure-session) by storing a random value used for CSRF token generation in the csrf attribute of a user's session. The @fastify/passport library does not clear the session object upon authentication, preserving the csrf attribute between pre-login and authenticated sessions. Consequently, CSRF tokens generated before authentication are still valid. Network and same-site attackers can thus obtain a CSRF token for their pre-session, fixate that pre-session in the victim's browser via cookie tossing, and then perform a CSRF attack after the victim authenticates. Fix As a solution, newer versions of @fastify/passport include the configuration options clearSessionOnLogin (default: true) and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2ccf-ffrj-m4qw

  2. Revision 1 · created ·

    Published from osv record GHSA-2ccf-ffrj-m4qw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-29020

Advisory: CSRF token fixation in fastify-passport
IDs: CVE-2023-29020, GHSA-2ccf-ffrj-m4qw
Record: https://patchnext.com/advisories/cve-2023-29020 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastify/passport 2.3.0, 1.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastify/passport: affected < 1.1.0; >= 2.0.0, < 2.3.0; fixed in 1.1.0, 2.3.0

## Suggested inspection (read-only)
- `npm ls @fastify/passport --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastify/passport.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2ccf-ffrj-m4qw (OSV record GHSA-2ccf-ffrj-m4qw lists affected ranges: npm @fastify/passport >=0 =2.0.0 <2.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2ccf-ffrj-m4qw (GitHub-reviewed advisory GHSA-2ccf-ffrj-m4qw lists affected ranges: npm @fastify/passport >=0 =2.0.0 <2.3.0)

Commands are suggestions: review each one before running it.

Loading voting…