Session fixation in fastify-passport
CVE-2023-29019GHSA-4m3m-ppvx-xgw9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/passport 2.3.0, 1.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.1.0>= 2.0.0, < 2.3.0
- Fixed in
- 1.1.0, 2.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4m3m-ppvx-xgw9 lists affected ranges: npm @fastify/passport >=0 =2.0.0 <2.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4m3m-ppvx-xgw9 lists affected ranges: npm @fastify/passport >=0 =2.0.0 <2.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-29019: 0.75% estimated exploitation activity in the next 30 days; percentile 55.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Applications using @fastify/passport for user authentication, in combination with @fastify/session as the underlying session management mechanism, are vulnerable to session fixation attacks from network and same-site attackers. Details fastify applications rely on the @fastify/passport library for user authentication. The login and user validation are performed by the authenticate function. When executing this function, the sessionId is preserved between the pre-login and the authenticated session. Network and same-site attackers can hijack the victim's session by tossing a valid sessionId cookie in the victim's browser and waiting for the victim to log in on the website. Fix As a solution, newer versions of @fastify/passport regenerate sessionId upon login, preventing the attacker-controlled pre-session cookie from being upgraded to an authenticated session. Credits Pedro Adão (@pedromigueladao), Instituto Superior Técnico, University of Lisbon Marco Squarcina (@lavish), Security &…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4m3m-ppvx-xgw9
- Revision 1 · created ·
Published from osv record GHSA-4m3m-ppvx-xgw9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-29019 Advisory: Session fixation in fastify-passport IDs: CVE-2023-29019, GHSA-4m3m-ppvx-xgw9 Record: https://patchnext.com/advisories/cve-2023-29019 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fastify/passport 2.3.0, 1.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fastify/passport: affected < 1.1.0; >= 2.0.0, < 2.3.0; fixed in 1.1.0, 2.3.0 ## Suggested inspection (read-only) - `npm ls @fastify/passport --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fastify/passport. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4m3m-ppvx-xgw9 (OSV record GHSA-4m3m-ppvx-xgw9 lists affected ranges: npm @fastify/passport >=0 =2.0.0 <2.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4m3m-ppvx-xgw9 (GitHub-reviewed advisory GHSA-4m3m-ppvx-xgw9 lists affected ranges: npm @fastify/passport >=0 =2.0.0 <2.3.0) Commands are suggestions: review each one before running it.
Loading voting…