Flask-AppBuilder Has No Rate Limiting on Login AUTH DB
CVE-2023-29005GHSA-9hcr-9hcv-x6pv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-appbuilder 4.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI flask-appbuilder
- Affected
- < 4.3.0
- Fixed in
- 4.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9hcr-9hcv-x6pv lists affected ranges: PyPI flask-appbuilder >=0 <4.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9hcr-9hcv-x6pv lists affected ranges: PyPI flask-appbuilder >=0 <4.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-29005: 0.63% estimated exploitation activity in the next 30 days; percentile 50.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Lack of rate limiting will allow an attacker to brute-force user credentials. Patches Ability to enable rate limiting on Flask-AppBuilder = 4.3.0. Use AUTHRATELIMITED = True and RATELIMITENABLED = True set the limit itself by using AUTHRATELIMIT. Will apply only to database authentication. Workarounds Implement rate limiting using a reverse proxy or other strategies.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9hcr-9hcv-x6pv
- Revision 1 · created ·
Published from osv record GHSA-9hcr-9hcv-x6pv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-29005 Advisory: Flask-AppBuilder Has No Rate Limiting on Login AUTH DB IDs: CVE-2023-29005, GHSA-9hcr-9hcv-x6pv Record: https://patchnext.com/advisories/cve-2023-29005 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flask-appbuilder 4.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI flask-appbuilder: affected < 4.3.0; fixed in 4.3.0 ## Suggested inspection (read-only) - `python -m pip show flask-appbuilder`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flask-appbuilder. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9hcr-9hcv-x6pv (OSV record GHSA-9hcr-9hcv-x6pv lists affected ranges: PyPI flask-appbuilder >=0 <4.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-9hcr-9hcv-x6pv (GitHub-reviewed advisory GHSA-9hcr-9hcv-x6pv lists affected ranges: PyPI flask-appbuilder >=0 <4.3.0) Commands are suggestions: review each one before running it.
Loading voting…