SvelteKit vulnerable to Cross-Site Request Forgery
CVE-2023-29003GHSA-5p75-vc5g-8rv2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sveltejs/kit 1.15.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @sveltejs/kit
- Affected
- < 1.15.1
- Fixed in
- 1.15.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5p75-vc5g-8rv2 lists affected ranges: npm @sveltejs/kit >=0 <1.15.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5p75-vc5g-8rv2 lists affected ranges: npm @sveltejs/kit >=0 <1.15.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-29003: 0.56% estimated exploitation activity in the next 30 days; percentile 46.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The SvelteKit framework offers developers an option to create simple REST APIs. This is done by defining a +server.js file, containing endpoint handlers for different HTTP methods. SvelteKit provides out-of-the-box cross-site request forgery (CSRF) protection to it’s users. The protection is implemented at kit/src/runtime/server/respond.js#L52. While the implementation does a sufficient job in mitigating common CSRF attacks, the protection can be bypassed by simply specifying a different Content-Type header value. Details The CSRF protection is implemented using the code shown below. If the incoming request specifies a POST method (1), the protection will compare the server’s origin with the value of the HTTP Origin header (2). A mismatch between these values signals that a potential attack has been detected. The final check is performed on the request’s Content-Type header (3) whether the value is either application/x-www-form-urlencoded or multipart/form-data…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5p75-vc5g-8rv2
- Revision 1 · created ·
Published from osv record GHSA-5p75-vc5g-8rv2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-29003 Advisory: SvelteKit vulnerable to Cross-Site Request Forgery IDs: CVE-2023-29003, GHSA-5p75-vc5g-8rv2 Record: https://patchnext.com/advisories/cve-2023-29003 (revision 2, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @sveltejs/kit 1.15.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @sveltejs/kit: affected < 1.15.1; fixed in 1.15.1 ## Suggested inspection (read-only) - `npm ls @sveltejs/kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @sveltejs/kit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5p75-vc5g-8rv2 (OSV record GHSA-5p75-vc5g-8rv2 lists affected ranges: npm @sveltejs/kit >=0 <1.15.1 (fixed)) - Verified: https://github.com/advisories/GHSA-5p75-vc5g-8rv2 (GitHub-reviewed advisory GHSA-5p75-vc5g-8rv2 lists affected ranges: npm @sveltejs/kit >=0 <1.15.1) Commands are suggestions: review each one before running it.
Loading voting…