Skip to content

← Actionable
Medium, CVSS 5.9

unpoly-rails Denial of Service vulnerability

CVE-2023-28846GHSA-m875-3xf6-mf78

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (unpoly-rails 2.7.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-28846: 1.03% estimated exploitation activity in the next 30 days; percentile 63.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a possible Denial of Service (DoS) vulnerability in the unpoly-rails gem that implements the Unpoly server protocol for Rails applications. Impact This issues affects Rails applications that operate as an upstream of a load balancer's that uses passive health checks. The unpoly-rails gem echoes the request URL as an X-Up-Location response header. By making a request with exceedingly long URLs (paths or query string), an attacker can cause unpoly-rails to write a exceedingly large response header. If the response header is too large to be parsed by a load balancer downstream of the Rails application, it may cause the load balancer to remove the upstream from a load balancing group. This causes that application instance to become unavailable until a configured timeout is reached or until an active healthcheck succeeds. Patches The fixed release 2.7.2.2+ is available via RubyGems and GitHub. Workarounds If you cannot upgrade to a fixed release, several workarounds are…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m875-3xf6-mf78

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28846

Advisory: unpoly-rails Denial of Service vulnerability
IDs: CVE-2023-28846, GHSA-m875-3xf6-mf78
Record: https://patchnext.com/advisories/cve-2023-28846 (revision 1, source checked 26 Oct 2026, 15:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: unpoly-rails 2.7.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems unpoly-rails: affected < 2.7.2.2; fixed in 2.7.2.2

## Suggested inspection (read-only)
- RubyGems unpoly-rails: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on unpoly-rails.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m875-3xf6-mf78 (GitHub-reviewed advisory GHSA-m875-3xf6-mf78 lists affected ranges: RubyGems unpoly-rails >=0 <2.7.2.2)

Commands are suggestions: review each one before running it.

Loading voting…