Skip to content

← Actionable
Medium, CVSS 6.8

Docker Swarm encrypted overlay network with a single endpoint is unauthenticated

CVE-2023-28842GHSA-6wrf-mxfj-pf5p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/docker/docker 23.0.3, 20.10.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N
EPSS
  • CVE-2023-28842: 1.44% estimated exploitation activity in the next 30 days; percentile 73.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Moby is an open source container framework developed by Docker Inc. that is distributed as Docker, Mirantis Container Runtime, and various other downstream projects/products. The Moby daemon component (dockerd), which is developed as moby/moby is commonly referred to as Docker. Swarm Mode, which is compiled in and delivered by default in dockerd and is thus present in most major Moby downstreams, is a simple, built-in container orchestrator that is implemented through a combination of SwarmKit and supporting network code. The overlay network driver is a core feature of Swarm Mode, providing isolated virtual LANs that allow communication between containers and services across the cluster. This driver is an implementation/user of VXLAN, which encapsulates link-layer (Ethernet) frames in UDP datagrams that tag the frame with a VXLAN Network ID (VNI) that identifies the originating overlay network. In addition, the overlay network driver supports an optional, off-by-default encrypted…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6wrf-mxfj-pf5p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28842

Advisory: Docker Swarm encrypted overlay network with a single endpoint is unauthenticated
IDs: CVE-2023-28842, GHSA-6wrf-mxfj-pf5p
Record: https://patchnext.com/advisories/cve-2023-28842 (revision 1, source checked 26 Oct 2026, 14:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/docker/docker 23.0.3, 20.10.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/docker/docker: affected >= 1.12.0, < 20.10.24; >= 23.0.0, < 23.0.3; fixed in 23.0.3, 20.10.24

## Suggested inspection (read-only)
- Go github.com/docker/docker: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/docker/docker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6wrf-mxfj-pf5p (GitHub-reviewed advisory GHSA-6wrf-mxfj-pf5p lists affected ranges: Go github.com/docker/docker >=1.12.0 =23.0.0 <23.0.3)

Commands are suggestions: review each one before running it.

Loading voting…