Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views
CVE-2023-28836GHSA-5286-f2rf-35c2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 4.2.2, 4.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wagtail
- Affected
- >= 1.5, < 4.1.4>= 4.2, < 4.2.2
- Fixed in
- 4.2.2, 4.1.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5286-f2rf-35c2 lists affected ranges: PyPI wagtail >=1.5 =4.2 <4.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5286-f2rf-35c2 lists affected ranges: PyPI wagtail >=1.5 =4.2 <4.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-28836: 0.78% estimated exploitation activity in the next 30 days; percentile 55.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A stored cross-site scripting (XSS) vulnerability exists on ModelAdmin views within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft pages and documents that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites with ModelAdmin enabled. - For page, the vulnerability is in the "Choose a parent page" ModelAdmin view (ChooseParentView), available when managing pages via ModelAdmin. - For documents, the vulnerability is in the ModelAdmin Inspect view (InspectView) when displaying document fields. Patches Patched versions have been released as Wagtail 4.1.4 (for the LTS 4.1 branch) and Wagtail 4.2.2 (for the current 4.2 branch). Workarounds Site owners who are unable to upgrade to the new versions can disable or override the corresponding…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5286-f2rf-35c2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5286-f2rf-35c2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-28836 Advisory: Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views IDs: CVE-2023-28836, GHSA-5286-f2rf-35c2 Record: https://patchnext.com/advisories/cve-2023-28836 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wagtail 4.2.2, 4.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wagtail: affected >= 1.5, < 4.1.4; >= 4.2, < 4.2.2; fixed in 4.2.2, 4.1.4 ## Suggested inspection (read-only) - `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wagtail. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5286-f2rf-35c2 (OSV record GHSA-5286-f2rf-35c2 lists affected ranges: PyPI wagtail >=1.5 =4.2 <4.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-5286-f2rf-35c2 (GitHub-reviewed advisory GHSA-5286-f2rf-35c2 lists affected ranges: PyPI wagtail >=1.5 =4.2 <4.2.2) Commands are suggestions: review each one before running it.
Loading voting…