Apache Tomcat - Fix for CVE-2023-24998 was incomplete
CVE-2023-28709GHSA-cx6h-86xw-9x34
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-coyote 8.5.88; org.apache.tomcat.embed:tomcat-embed-core 11.0.0-M5, 10.1.8, 9.0.74), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-coyote
- Affected
- >= 8.5.85, < 8.5.88
- Fixed in
- 8.5.88
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 11.0.0-M2, < 11.0.0-M5>= 10.1.5, < 10.1.8>= 9.0.71, < 9.0.74
- Fixed in
- 10.1.8, 11.0.0-M5, 9.0.74
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cx6h-86xw-9x34 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=11.0.0-M2 =10.1.5 =9.0.71 =8.5.85 <8.5.88
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-28709: 48.03% estimated exploitation activity in the next 30 days; percentile 98.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The fix for CVE-2023-24998 was incomplete. If non-default HTTP connector settings were used such that the maxParameterCount could be reached using query string parameters and a request was submitted that supplied exactly maxParameterCount parameters in the query string, the limit for uploaded request parts could be bypassed with the potential for a denial of service to occur.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cx6h-86xw-9x34
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-28709 Advisory: Apache Tomcat - Fix for CVE-2023-24998 was incomplete IDs: CVE-2023-28709, GHSA-cx6h-86xw-9x34 Record: https://patchnext.com/advisories/cve-2023-28709 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-coyote 8.5.88; org.apache.tomcat.embed:tomcat-embed-core 11.0.0-M5, 10.1.8, 9.0.74. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-coyote: affected >= 8.5.85, < 8.5.88; fixed in 8.5.88 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M2, < 11.0.0-M5; >= 10.1.5, < 10.1.8; >= 9.0.71, < 9.0.74; fixed in 10.1.8, 11.0.0-M5, 9.0.74 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cx6h-86xw-9x34 (GitHub-reviewed advisory GHSA-cx6h-86xw-9x34 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=11.0.0-M2 =10.1.5 =9.0.71 =8.5.85 <8.5.88) Commands are suggestions: review each one before running it.
Loading voting…