Defining resource name as integer may give unintended access in vantage6
CVE-2023-28635GHSA-7x94-6g2m-3hp2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vantage6-node 4.0.0; vantage6 4.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vantage6-node
- Affected
- < 4.0.0
- Fixed in
- 4.0.0
PyPI vantage6
- Affected
- < 4.0.0
- Fixed in
- 4.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7x94-6g2m-3hp2 lists affected ranges: PyPI vantage6 >=0 <4.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2023-198 lists affected ranges: PyPI vantage6-node >=0 <4.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7x94-6g2m-3hp2 lists affected ranges: PyPI vantage6 >=0 <4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-28635: 0.50% estimated exploitation activity in the next 30 days; percentile 43.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Malicious users may try to get access to resources they are not allowed to see, by creating resources with integers as names. One example where this is a risk, is when users define which users are allowed to run algorithms on their node. This may be defined by username or user id. Now, for example, if user id 13 is allowed to run tasks, and an attacker creates a username with username '13', they would be wrongly allowed to run an algorithm. There may also be other places in the code where such a mixup of resource ID or name leads to issues. The best solution we see is therefore to check when resources are created or modified, that the resource name always starts with a character. Patches To be done, probably in v3.9 Workarounds None
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-7x94-6g2m-3hp2
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record PYSEC-2023-198
- Revision 1 · created ·
Published from osv record GHSA-7x94-6g2m-3hp2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-28635 Advisory: Defining resource name as integer may give unintended access in vantage6 IDs: CVE-2023-28635, GHSA-7x94-6g2m-3hp2 Record: https://patchnext.com/advisories/cve-2023-28635 (revision 4, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vantage6-node 4.0.0; vantage6 4.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vantage6-node: affected < 4.0.0; fixed in 4.0.0 - PyPI vantage6: affected < 4.0.0; fixed in 4.0.0 ## Suggested inspection (read-only) - `python -m pip show vantage6-node`: prints the installed version. Run with the environment that serves production active. - `python -m pip show vantage6`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vantage6-node, vantage6. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7x94-6g2m-3hp2 (OSV record GHSA-7x94-6g2m-3hp2 lists affected ranges: PyPI vantage6 >=0 <4.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2023-198 (OSV record PYSEC-2023-198 lists affected ranges: PyPI vantage6-node >=0 <4.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7x94-6g2m-3hp2 (GitHub-reviewed advisory GHSA-7x94-6g2m-3hp2 lists affected ranges: PyPI vantage6 >=0 <4.0.0) Commands are suggestions: review each one before running it.
Loading voting…