Skip to content

← Actionable
Medium, CVSS 6.5

lambdaisland/uri authority-regex returns the wrong authority

CVE-2023-28628GHSA-cp4w-6x4w-v2h5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lambdaisland:uri 1.14.120), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-28628: 0.55% estimated exploitation activity in the next 30 days; percentile 45.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary authority-regex allows an attacker to send malicious URLs to be parsed by the lambdaisland/uri and return the wrong authority. This issue is similar to CVE-2020-8910. Details https://github.com/lambdaisland/uri/blob/d3355fcd3e235238f4dcd37be97787a84e580072/src/lambdaisland/uri.cljc#L9 This regex doesn't handle the backslash (\) character in the username correctly, leading to a wrong output. Payload: https://example.com\\@google.com The returned host is google.com, but the correct host should be example.com. urllib3 (Python) and google-closure-library (Javascript) return example.com as the host. Here the correct (or current) regex used by google-closure-library: https://github.com/google/closure-library/blob/0e567abedb058e9b194a40cfa3ad4c507653bccf/closure/goog/uri/utils.js#L189 PoC Impact The library returns the wrong authority, and it can be abused to bypass host restrictions. Reference WHATWG Living URL spec, section 4.4 URL Parsing, host state:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cp4w-6x4w-v2h5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28628

Advisory: lambdaisland/uri `authority-regex` returns the wrong authority
IDs: CVE-2023-28628, GHSA-cp4w-6x4w-v2h5
Record: https://patchnext.com/advisories/cve-2023-28628 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lambdaisland:uri 1.14.120. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven lambdaisland:uri: affected < 1.14.120; fixed in 1.14.120

## Suggested inspection (read-only)
- Maven lambdaisland:uri: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lambdaisland:uri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cp4w-6x4w-v2h5 (GitHub-reviewed advisory GHSA-cp4w-6x4w-v2h5 lists affected ranges: Maven lambdaisland:uri >=0 <1.14.120)

Commands are suggestions: review each one before running it.

Loading voting…