Unintentional leakage of private information via cross-origin websocket session hijacking
CVE-2023-2850GHSA-4qcv-qf38-5j3j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodebb 3.1.3, 2.8.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nodebb
- Affected
- >= 3.0.0, < 3.1.3< 2.8.13
- Fixed in
- 2.8.13, 3.1.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4qcv-qf38-5j3j lists affected ranges: npm nodebb >=3.0.0 =0 <2.8.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4qcv-qf38-5j3j lists affected ranges: npm nodebb >=3.0.0 =0 <2.8.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.7 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
- EPSS
- CVE-2023-2850: 0.33% estimated exploitation activity in the next 30 days; percentile 26.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Private messages or posts might be leaked to third parties if victim opens the attackers site while browsing nodebb. Patches Patched in v3.1.3 Backported to v2.x line via v2.8.13 Workarounds Users can cherry-pick https://github.com/NodeBB/NodeBB/commit/51096ad2345fb1d1380bec0a447113489ef6c359 if they are on v3.x If you are running v2.x of NodeBB, you can cherry-pick a5d92da9ddac5607ab7f737520a66eaed6d3ddee followed by 62e162cf1e735e42462be1db9b4954b5a69accdf
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4qcv-qf38-5j3j
- Revision 1 · created ·
Published from osv record GHSA-4qcv-qf38-5j3j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-2850 Advisory: Unintentional leakage of private information via cross-origin websocket session hijacking IDs: CVE-2023-2850, GHSA-4qcv-qf38-5j3j Record: https://patchnext.com/advisories/cve-2023-2850 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nodebb 3.1.3, 2.8.13. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nodebb: affected >= 3.0.0, < 3.1.3; < 2.8.13; fixed in 2.8.13, 3.1.3 ## Suggested inspection (read-only) - `npm ls nodebb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nodebb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4qcv-qf38-5j3j (OSV record GHSA-4qcv-qf38-5j3j lists affected ranges: npm nodebb >=3.0.0 =0 <2.8.13 (fixed)) - Verified: https://github.com/advisories/GHSA-4qcv-qf38-5j3j (GitHub-reviewed advisory GHSA-4qcv-qf38-5j3j lists affected ranges: npm nodebb >=3.0.0 =0 <2.8.13) Commands are suggestions: review each one before running it.
Loading voting…