Skip to content

← Actionable
High, CVSS 8.8

Interactive run permission prompt spoofing via improper ANSI neutralization

CVE-2023-28446GHSA-vq67-rp93-65qf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (deno_runtime 1.31.2; deno 1.31.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io deno_runtime

    Affected
    >= 1.8.0, < 1.31.2
    Fixed in
    1.31.2
  • crates.io deno

    Affected
    >= 1.8.0, < 1.31.2
    Fixed in
    1.31.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-28446: 1.13% estimated exploitation activity in the next 30 days; percentile 66.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Arbitrary program names without any ANSI filtering allows any malicious program to clear the first 2 lines of a opspawnchild or opkill prompt and replace it with any desired text. Details The main entry point comes down to the ability to override what the API control says (40process.js). Because of ANSI code's ability to clear lines, a malicious program can clear the last 2 lines of the prompt and put their own header. This also works in opkill. PoC This PoC works on 1.31.1, but modified versions of it work on older versions. Make a file, e.g. index.ts, that uses this vulnerability to spoof the opspawnchild permission prompt Run the file with deno run index.ts. Impact Any Deno program is able to spoof the interactive permission prompt for the opspawnchild or the opkill action (which indirectly gives access to all run commands) by overriding the Requested by {message} API with their own ANSI codes, allowing them to clear the latter prompt and change it to whatever they needed:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vq67-rp93-65qf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28446

Advisory: Interactive `run` permission prompt spoofing via improper ANSI neutralization
IDs: CVE-2023-28446, GHSA-vq67-rp93-65qf
Record: https://patchnext.com/advisories/cve-2023-28446 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: deno_runtime 1.31.2; deno 1.31.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io deno_runtime: affected >= 1.8.0, < 1.31.2; fixed in 1.31.2
- crates.io deno: affected >= 1.8.0, < 1.31.2; fixed in 1.31.2

## Suggested inspection (read-only)
- crates.io deno_runtime: check the installed version with your package manager.
- crates.io deno: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on deno_runtime, deno.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vq67-rp93-65qf (GitHub-reviewed advisory GHSA-vq67-rp93-65qf lists affected ranges: crates.io deno_runtime >=1.8.0 =1.8.0 <1.31.2)

Commands are suggestions: review each one before running it.

Loading voting…