Deno improperly handles resizable ArrayBuffer
CVE-2023-28445GHSA-c25x-cm9x-qqgx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (Deno 1.32.1; serde_v8 0.88.0; deno_runtime 0.103.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io Deno
- Affected
- >= 1.32.0, <= 1.32.0
- Fixed in
- 1.32.1
crates.io serde_v8
- Affected
- >= 0.87.0, <= 0.87.0
- Fixed in
- 0.88.0
crates.io deno_runtime
- Affected
- >= 0.102.0, <= 0.102.0
- Fixed in
- 0.103.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c25x-cm9x-qqgx lists affected ranges: crates.io Deno >=1.32.0 =0.87.0 =0.102.0 <=0.102.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-28445: 0.97% estimated exploitation activity in the next 30 days; percentile 61.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Resizable ArrayBuffers passed to asynchronous native functions that are shrunk during the asynchronous operation could result in an out-of-bound read/write. It is unlikely that this has been exploited in the wild, as the only version affected is Deno 1.32.0. Deno Deploy users are not affected. Patches The problem has been resolved by disabling resizable ArrayBuffers temporarily in Deno 1.32.1. A future version of Deno will re-enable resizable ArrayBuffers with a proper fix. Workarounds Upgrade to Deno 1.32.1, or run with --v8-flags=--no-harmony-rab-gsab to disable resizable ArrayBuffers.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c25x-cm9x-qqgx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-28445 Advisory: Deno improperly handles resizable ArrayBuffer IDs: CVE-2023-28445, GHSA-c25x-cm9x-qqgx Record: https://patchnext.com/advisories/cve-2023-28445 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: Deno 1.32.1; serde_v8 0.88.0; deno_runtime 0.103.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io Deno: affected >= 1.32.0, <= 1.32.0; fixed in 1.32.1 - crates.io serde_v8: affected >= 0.87.0, <= 0.87.0; fixed in 0.88.0 - crates.io deno_runtime: affected >= 0.102.0, <= 0.102.0; fixed in 0.103.0 ## Suggested inspection (read-only) - crates.io Deno: check the installed version with your package manager. - crates.io serde_v8: check the installed version with your package manager. - crates.io deno_runtime: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on Deno, serde_v8, deno_runtime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c25x-cm9x-qqgx (GitHub-reviewed advisory GHSA-c25x-cm9x-qqgx lists affected ranges: crates.io Deno >=1.32.0 =0.87.0 =0.102.0 <=0.102.0) Commands are suggestions: review each one before running it.
Loading voting…