angular-server-side-configuration information disclosure vulnerability in monorepo with node.js backend
CVE-2023-28444GHSA-gwvm-vrp4-4pp5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (angular-server-side-configuration 15.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm angular-server-side-configuration
- Affected
- >= 15.0.0, < 15.1.0
- Fixed in
- 15.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gwvm-vrp4-4pp5 lists affected ranges: npm angular-server-side-configuration >=15.0.0 <15.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gwvm-vrp4-4pp5 lists affected ranges: npm angular-server-side-configuration >=15.0.0 <15.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L
- EPSS
- CVE-2023-28444: 0.76% estimated exploitation activity in the next 30 days; percentile 55.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact angular-server-side-configuration detects used environment variables in TypeScript (.ts) files during build time of an Angular CLI project. The detected environment variables are written to a ngssc.json file in the output directory. During deployment of an Angular based app, the environment variables based on the variables from ngssc.json are inserted into the apps index.html (or defined index file). With version 15 the environment variable detection was widened to the entire project, relative to the angular.json file from the Angular CLI. In a monorepo setup, this could lead to environment variables intended for a backend/service to be detected and written to the ngssc.json, which would then be populated and exposed via index.html. This has NO IMPACT, in a plain Angular project that has no backend component. Patches Vulnerability has been mitigated in 15.1.0, by adding an option searchPattern which restricts the detection file range by default. Workarounds Manually edit or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gwvm-vrp4-4pp5
- Revision 1 · created ·
Published from osv record GHSA-gwvm-vrp4-4pp5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-28444 Advisory: angular-server-side-configuration information disclosure vulnerability in monorepo with node.js backend IDs: CVE-2023-28444, GHSA-gwvm-vrp4-4pp5 Record: https://patchnext.com/advisories/cve-2023-28444 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: angular-server-side-configuration 15.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm angular-server-side-configuration: affected >= 15.0.0, < 15.1.0; fixed in 15.1.0 ## Suggested inspection (read-only) - `npm ls angular-server-side-configuration --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on angular-server-side-configuration. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gwvm-vrp4-4pp5 (OSV record GHSA-gwvm-vrp4-4pp5 lists affected ranges: npm angular-server-side-configuration >=15.0.0 <15.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-gwvm-vrp4-4pp5 (GitHub-reviewed advisory GHSA-gwvm-vrp4-4pp5 lists affected ranges: npm angular-server-side-configuration >=15.0.0 <15.1.0) Commands are suggestions: review each one before running it.
Loading voting…