directus vulnerable to Insertion of Sensitive Information into Log File
CVE-2023-28443GHSA-8vg2-wf3q-mwv7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 9.23.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- < 9.23.3
- Fixed in
- 9.23.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8vg2-wf3q-mwv7 lists affected ranges: npm directus >=0 <9.23.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8vg2-wf3q-mwv7 lists affected ranges: npm directus >=0 <9.23.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-28443: 0.31% estimated exploitation activity in the next 30 days; percentile 24.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary CWE-532: Insertion of Sensitive Information into Log File discovered in v9.23.1. The directusrefreshtoken is not redacted properly from the log outputs and can be used to impersonate users without their permission. Details Using v9.23.1, I am seeing that the directusrefreshtoken is not properly redacted as indicated by https://github.com/directus/directus/blob/7c479c5161639aac466c763b6b958a9524201d74/api/src/logger.ts#L13 I'm classifying this as a security vulnerability because if someone has access to the log outputs, for example with a shared Cloud account or Splunk implementation, they could exchange the refresh token using /auth/refresh for an access token and use the token to perform actions on behalf of an unsuspecting user. This situation creates issues with accountability and non-repudiation because we can no longer have confidence that actions taken in the application were authorized or even performed by the logged-in user. A couple of examples of this are: - A…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8vg2-wf3q-mwv7
- Revision 1 · created ·
Published from osv record GHSA-8vg2-wf3q-mwv7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-28443 Advisory: directus vulnerable to Insertion of Sensitive Information into Log File IDs: CVE-2023-28443, GHSA-8vg2-wf3q-mwv7 Record: https://patchnext.com/advisories/cve-2023-28443 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 9.23.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected < 9.23.3; fixed in 9.23.3 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8vg2-wf3q-mwv7 (OSV record GHSA-8vg2-wf3q-mwv7 lists affected ranges: npm directus >=0 <9.23.3 (fixed)) - Verified: https://github.com/advisories/GHSA-8vg2-wf3q-mwv7 (GitHub-reviewed advisory GHSA-8vg2-wf3q-mwv7 lists affected ranges: npm directus >=0 <9.23.3) Commands are suggestions: review each one before running it.
Loading voting…