Privilege Escalation on Linux/MacOS
CVE-2023-28434GHSA-2pxw-r47w-4p8c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/minio/minio 0.0.0-202303200415), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.0.0-202303200415
- Fixed in
- 0.0.0-202303200415
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2pxw-r47w-4p8c lists affected ranges: Go github.com/minio/minio >=0 <0.0.0-202303200415
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2023-28434 to the Known Exploited Vulnerabilities catalog on 2023-09-19.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2023-09-19).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:H
- EPSS
- CVE-2023-28434: 7.92% estimated exploitation activity in the next 30 days; percentile 94.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker can use crafted requests to bypass metadata bucket name checking and put an object into any bucket while processing PostPolicyBucket. To carry out this attack, the attacker requires credentials with arn:aws:s3::: permission, as well as enabled Console API access. Patches Workarounds Browser API access must be enabled turning off MINIOBROWSER=off allows for this workaround. References The vulnerable code:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2pxw-r47w-4p8c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-28434 Advisory: Privilege Escalation on Linux/MacOS IDs: CVE-2023-28434, GHSA-2pxw-r47w-4p8c Record: https://patchnext.com/advisories/cve-2023-28434 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: github.com/minio/minio 0.0.0-202303200415. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/minio/minio: affected < 0.0.0-202303200415; fixed in 0.0.0-202303200415 ## Suggested inspection (read-only) - Go github.com/minio/minio: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/minio/minio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2pxw-r47w-4p8c (GitHub-reviewed advisory GHSA-2pxw-r47w-4p8c lists affected ranges: Go github.com/minio/minio >=0 <0.0.0-202303200415) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2023-28434 to the Known Exploited Vulnerabilities catalog on 2023-09-19.) Commands are suggestions: review each one before running it.
Loading voting…