Skip to content

← Actionable
Medium, CVSS 4.0

Actionpack has possible cross-site scripting vulnerability via User Supplied Values to redirect_to

CVE-2023-28362GHSA-4g8v-vg43-wpgf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionpack 7.0.5.1, 6.1.7.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems actionpack

    Affected
    < 6.1.7.4>= 7.0.0, < 7.0.5.1
    Fixed in
    7.0.5.1, 6.1.7.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.0 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2023-28362: 0.33% estimated exploitation activity in the next 30 days; percentile 26.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The redirectto method in Rails allows provided values to contain characters which are not legal in an HTTP header value. This results in the potential for downstream services which enforce RFC compliance on HTTP response headers to remove the assigned Location header. This vulnerability has been assigned the CVE identifier CVE-2023-28362. Versions Affected: All. Not affected: None Fixed Versions: 7.0.5.1, 6.1.7.4 Impact This introduces the potential for a Cross-site-scripting (XSS) payload to be delivered on the now static redirection page. Note that this both requires user interaction and for a Rails app to be configured to allow redirects to external hosts (defaults to false in Rails = 7.0.x). Releases The FIXED releases are available at the normal locations. Workarounds Avoid providing user supplied URLs with arbitrary schemes to the redirectto method.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4g8v-vg43-wpgf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28362

Advisory: Actionpack has possible cross-site scripting vulnerability via User Supplied Values to redirect_to
IDs: CVE-2023-28362, GHSA-4g8v-vg43-wpgf
Record: https://patchnext.com/advisories/cve-2023-28362 (revision 1, source checked 26 Oct 2026, 15:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: actionpack 7.0.5.1, 6.1.7.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems actionpack: affected < 6.1.7.4; >= 7.0.0, < 7.0.5.1; fixed in 7.0.5.1, 6.1.7.4

## Suggested inspection (read-only)
- RubyGems actionpack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on actionpack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4g8v-vg43-wpgf (GitHub-reviewed advisory GHSA-4g8v-vg43-wpgf lists affected ranges: RubyGems actionpack >=0 =7.0.0 <7.0.5.1)

Commands are suggestions: review each one before running it.

Loading voting…