Skip to content

← Actionable
Critical, CVSS 9.8

Moodle's Mustache pix helper contained a potential Mustache injection risk if combined with user input

CVE-2023-28333GHSA-q2x3-2f9g-h559

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.1.2, 4.0.7, 3.11.13, 3.9.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 4.1.0, < 4.1.2>= 4.0.0, < 4.0.7>= 3.11.0, < 3.11.13< 3.9.20
    Fixed in
    3.11.13, 3.9.20, 4.1.2, 4.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-28333: 1.17% estimated exploitation activity in the next 30 days; percentile 67.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Mustache pix helper contained a potential Mustache injection risk if combined with user input (note: This did not appear to be implemented/exploitable anywhere in the core Moodle LMS).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q2x3-2f9g-h559

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28333

Advisory: Moodle's Mustache pix helper contained a potential Mustache injection risk if combined with user input
IDs: CVE-2023-28333, GHSA-q2x3-2f9g-h559
Record: https://patchnext.com/advisories/cve-2023-28333 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.1.2, 4.0.7, 3.11.13, 3.9.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 4.1.0, < 4.1.2; >= 4.0.0, < 4.0.7; >= 3.11.0, < 3.11.13; < 3.9.20; fixed in 3.11.13, 3.9.20, 4.1.2, 4.0.7

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q2x3-2f9g-h559 (GitHub-reviewed advisory GHSA-q2x3-2f9g-h559 lists affected ranges: Packagist moodle/moodle >=4.1.0 =4.0.0 =3.11.0 =0 <3.9.20)

Commands are suggestions: review each one before running it.

Loading voting…