Skip to content

← Actionable
Medium, CVSS 6.1amended

Server-Side Request Forgery in Request

CVE-2023-28155GHSA-p8p7-x288-28g6

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm request

    Affected
    <= 2.88.2
    Fixed in
    no fixed version recorded
  • npm @cypress/request

    Affected
    <= 2.88.12
    Fixed in
    3.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-28155: 0.72% estimated exploitation activity in the next 30 days; percentile 53.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The request package through 2.88.2 for Node.js and the @cypress/request package prior to 3.0.0 allow a bypass of SSRF mitigations via an attacker-controller server that does a cross-protocol redirect (HTTP to HTTPS, or HTTPS to HTTP). NOTE: The request package is no longer supported by the maintainer.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p8p7-x288-28g6

  2. Revision 1 · created ·

    Published from osv record GHSA-p8p7-x288-28g6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28155

Advisory: Server-Side Request Forgery in Request
IDs: CVE-2023-28155, GHSA-p8p7-x288-28g6
Record: https://patchnext.com/advisories/cve-2023-28155 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @cypress/request 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm request: affected <= 2.88.2
- npm @cypress/request: affected <= 2.88.12; fixed in 3.0.0

## Suggested inspection (read-only)
- `npm ls request --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @cypress/request --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on request, @cypress/request.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p8p7-x288-28g6 (OSV record GHSA-p8p7-x288-28g6 lists affected ranges: npm request >=0 =0 <3.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-p8p7-x288-28g6 (GitHub-reviewed advisory GHSA-p8p7-x288-28g6 lists affected ranges: npm request >=0 =0 <=2.88.12)

Commands are suggestions: review each one before running it.

Loading voting…