Skip to content

← Actionable
Critical, CVSS 9.6amended

Expo SDK has an OAuth vulnerability

CVE-2023-28131GHSA-wr5g-q49g-548w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (expo 48.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm expo

    Affected
    < 48.0.0
    Fixed in
    48.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-28131: 23.16% estimated exploitation activity in the next 30 days; percentile 97.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability in the expo.io framework allows an attacker to take over accounts and steal credentials on an application/website that configured the "Expo AuthSession Redirect Proxy" for social sign-in. This can be achieved once a victim clicks a malicious link. The link itself may be sent to the victim in various ways (including email, text message, an attacker-controlled website, etc).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wr5g-q49g-548w

  2. Revision 1 · created ·

    Published from osv record GHSA-wr5g-q49g-548w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28131

Advisory: Expo SDK has an OAuth vulnerability
IDs: CVE-2023-28131, GHSA-wr5g-q49g-548w
Record: https://patchnext.com/advisories/cve-2023-28131 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: expo 48.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm expo: affected < 48.0.0; fixed in 48.0.0

## Suggested inspection (read-only)
- `npm ls expo --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on expo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wr5g-q49g-548w (OSV record GHSA-wr5g-q49g-548w lists affected ranges: npm expo >=0 <48.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-wr5g-q49g-548w (GitHub-reviewed advisory GHSA-wr5g-q49g-548w lists affected ranges: npm expo >=0 <48.0.0)

Commands are suggestions: review each one before running it.

Loading voting…