Skip to content

← Actionable
Medium, CVSS 5.3

Possible XSS Security Vulnerability in SafeBuffer#bytesplice

CVE-2023-28120GHSA-pj73-v5mw-pm9j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (activesupport 7.0.4.3, 6.1.7.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems activesupport

    Affected
    >= 7.0.0, < 7.0.4.3< 6.1.7.3
    Fixed in
    6.1.7.3, 7.0.4.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2023-28120: 0.95% estimated exploitation activity in the next 30 days; percentile 61.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a vulnerability in ActiveSupport if the new bytesplice method is called on a SafeBuffer with untrusted user input. This vulnerability has been assigned the CVE identifier CVE-2023-28120. Versions Affected: All. Not affected: None Fixed Versions: 7.0.4.3, 6.1.7.3 Impact ActiveSupport uses the SafeBuffer string subclass to tag strings as htmlsafe after they have been sanitized. When these strings are mutated, the tag is should be removed to mark them as no longer being htmlsafe. Ruby 3.2 introduced a new bytesplice method which ActiveSupport did not yet understand to be a mutation. Users on older versions of Ruby are likely unaffected. All users running an affected release and using bytesplice should either upgrade or use one of the workarounds immediately. Workarounds Avoid calling bytesplice on a SafeBuffer (htmlsafe) string with untrusted user input.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pj73-v5mw-pm9j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28120

Advisory: Possible XSS Security Vulnerability in SafeBuffer#bytesplice
IDs: CVE-2023-28120, GHSA-pj73-v5mw-pm9j
Record: https://patchnext.com/advisories/cve-2023-28120 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: activesupport 7.0.4.3, 6.1.7.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems activesupport: affected >= 7.0.0, < 7.0.4.3; < 6.1.7.3; fixed in 6.1.7.3, 7.0.4.3

## Suggested inspection (read-only)
- RubyGems activesupport: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on activesupport.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pj73-v5mw-pm9j (GitHub-reviewed advisory GHSA-pj73-v5mw-pm9j lists affected ranges: RubyGems activesupport >=7.0.0 =0 <6.1.7.3)

Commands are suggestions: review each one before running it.

Loading voting…