Skip to content

← Actionable
High, CVSS 7.6amended

Sentry SDK leaks sensitive session information when sendDefaultPII is set to True

CVE-2023-28117GHSA-29pr-6jr8-q5jm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry-sdk 1.14.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2023-28117: 0.65% estimated exploitation activity in the next 30 days; percentile 51.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When using the Django integration of the Sentry SDK in a specific configuration it is possible to leak sensitive cookies values, including the session cookie to Sentry. These sensitive cookies could then be used by someone with access to your Sentry issues to impersonate or escalate their privileges within your application. The below must be true in order for these sensitive values to be leaked: 1. Your Sentry SDK configuration has sendDefaultPII set to True 2. You are using a custom name for either of the cookies below in your Django settings. - SESSIONCOOKIENAME or - CSRFCOOKIENAME Django settings 3. You are not configured in your organization or project settings to use our data scrubbing features to account for the custom cookie names Patches As of version 1.14.0, the Django integration of the sentry-sdk will detect the custom cookie names based on your Django settings and will remove the values from the payload before sending the data to Sentry. Workarounds If you can not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-29pr-6jr8-q5jm

  2. Revision 1 · created ·

    Published from osv record GHSA-29pr-6jr8-q5jm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28117

Advisory: Sentry SDK leaks sensitive session information when `sendDefaultPII` is set to `True`
IDs: CVE-2023-28117, GHSA-29pr-6jr8-q5jm
Record: https://patchnext.com/advisories/cve-2023-28117 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sentry-sdk 1.14.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI sentry-sdk: affected < 1.14.0; fixed in 1.14.0

## Suggested inspection (read-only)
- `python -m pip show sentry-sdk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sentry-sdk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-29pr-6jr8-q5jm (OSV record GHSA-29pr-6jr8-q5jm lists affected ranges: PyPI sentry-sdk >=0 <1.14.0 (fixed))
- Verified: https://github.com/advisories/GHSA-29pr-6jr8-q5jm (GitHub-reviewed advisory GHSA-29pr-6jr8-q5jm lists affected ranges: PyPI sentry-sdk >=0 <1.14.0)

Commands are suggestions: review each one before running it.

Loading voting…