Skip to content

← Actionable
Critical, CVSS 9.8

PHAR deserialization allowing remote code execution

CVE-2023-28115GHSA-gq6w-q6wh-jggc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (knplabs/knp-snappy 1.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-28115: 2.76% estimated exploitation activity in the next 30 days; percentile 86.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description snappy is vulnerable to PHAR deserialization due to a lack of checking on the protocol before passing it into the fileexists() function. If an attacker can upload files of any type to the server he can pass in the phar:// protocol to unserialize the uploaded file and instantiate arbitrary PHP objects. This can lead to remote code execution especially when snappy is used with frameworks with documented POP chains like Laravel/Symfony vulnerable developer code. If user can control the output file from the generateFromHtml() function, it will invoke deserialization. Proof of Concept Install Snappy via composer require knplabs/knp-snappy. After that, under snappy directory, create an index.php file with this vulnerable code. As an attacker, we going to generate the malicious phar using this script. Then run these command to generate the file Then execute index.php with php index.php. You will see a file named pwned will be created. Noted that attacker can upload a file with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gq6w-q6wh-jggc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28115

Advisory: PHAR deserialization allowing remote code execution
IDs: CVE-2023-28115, GHSA-gq6w-q6wh-jggc
Record: https://patchnext.com/advisories/cve-2023-28115 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: knplabs/knp-snappy 1.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist knplabs/knp-snappy: affected < 1.4.2; fixed in 1.4.2

## Suggested inspection (read-only)
- Packagist knplabs/knp-snappy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on knplabs/knp-snappy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gq6w-q6wh-jggc (GitHub-reviewed advisory GHSA-gq6w-q6wh-jggc lists affected ranges: Packagist knplabs/knp-snappy >=0 <1.4.2)

Commands are suggestions: review each one before running it.

Loading voting…