Skip to content

← Actionable
Medium, CVSS 5.9

russh may use insecure Diffie-Hellman keys

CVE-2023-28113GHSA-cqvm-j2r2-hwpg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (russh 0.37.1, 0.36.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io russh

    Affected
    < 0.36.2>= 0.37.0, < 0.37.1
    Fixed in
    0.37.1, 0.36.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-28113: 0.64% estimated exploitation activity in the next 30 days; percentile 50.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Diffie-Hellman key validation is insufficient, which can lead to insecure shared secrets and therefore breaks confidentiality. Details Russh does not validate Diffie-Hellman keys. It accepts received DH public keys $e$ where $e<0$, $e=1$, or $e \geq p-1$ from a misbehaving peer annd successfully performs key exchange. This is a violation of RFC 4253, section 8 and RFC 8268, section 4, which state that: DH Public Key values MUST be checked and both conditions: - $1 < e < p-1$ - $1 < f < p-1$ MUST be true. Values not within these bounds MUST NOT be sent or accepted by either side. If either one of these conditions is violated, then the key exchange fails. For example, a DH client public key $e=1$ would mean that the shared secret that the server calculates is always $K = e^y \mod{p} = 1^y \mod{p} = 1$. In other cases, an insecure order-2 subgroup may be used. Also, the code does not look like it ensures that the generated secret key $y$ is in the valid interval $0 < y < q$ (or,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cqvm-j2r2-hwpg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28113

Advisory: russh may use insecure Diffie-Hellman keys
IDs: CVE-2023-28113, GHSA-cqvm-j2r2-hwpg
Record: https://patchnext.com/advisories/cve-2023-28113 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: russh 0.37.1, 0.36.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io russh: affected < 0.36.2; >= 0.37.0, < 0.37.1; fixed in 0.37.1, 0.36.2

## Suggested inspection (read-only)
- crates.io russh: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on russh.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cqvm-j2r2-hwpg (GitHub-reviewed advisory GHSA-cqvm-j2r2-hwpg lists affected ranges: crates.io russh >=0 =0.37.0 <0.37.1)

Commands are suggestions: review each one before running it.

Loading voting…