Skip to content

← Actionable
High, CVSS 7.5

DDOS attack on graphql endpoints

CVE-2023-28104GHSA-67g8-c724-8mp3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/graphql 4.2.3, 4.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-28104: 1.05% estimated exploitation activity in the next 30 days; percentile 64.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An attacker could use a specially crafted graphql query to execute a Distributed Denial of Service attack (DDOS attack) against a website. This mostly affects websites with publicly exposed and particularly large/complex graphql schemas. If your Silverstripe CMS project does not expose a public facing graphql schema, a user account is required to trigger the DDOS attack. If your site is hosted behind a content delivery network (CDN), such as Imperva or CloudFlare, this will likely further mitigate the risk. Upgrade to silverstripe/graphql 4.2.3 or 4.1.2 or above to remedy the vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-67g8-c724-8mp3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28104

Advisory: DDOS attack on graphql endpoints
IDs: CVE-2023-28104, GHSA-67g8-c724-8mp3
Record: https://patchnext.com/advisories/cve-2023-28104 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/graphql 4.2.3, 4.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/graphql: affected >= 4.1.1, < 4.1.2; >= 4.2.2, < 4.2.3; fixed in 4.1.2, 4.2.3

## Suggested inspection (read-only)
- Packagist silverstripe/graphql: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/graphql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-67g8-c724-8mp3 (GitHub-reviewed advisory GHSA-67g8-c724-8mp3 lists affected ranges: Packagist silverstripe/graphql >=4.1.1 =4.2.2 <4.2.3)

Commands are suggestions: review each one before running it.

Loading voting…