Skip to content

← Actionable
Medium, CVSS 6.5

Denial of service in Jenkins Core

CVE-2023-27900GHSA-frgr-c5f2-8qhh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.main:jenkins-core 2.394, 2.387.1, 2.375.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-27900: 0.98% estimated exploitation activity in the next 30 days; percentile 62.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins 2.393 and earlier, LTS 2.375.3 and earlier, and prior to LTS 2.387.1 is affected by the Apache Commons FileUpload library’s vulnerability CVE-2023-24998. This library is used to process uploaded files via the Stapler web framework (usually through StaplerRequest#getFile) and MultipartFormDataParser in Jenkins. This allows attackers to cause a denial of service (DoS) by sending crafted requests to HTTP endpoints processing file uploads. Jenkins 2.394, LTS 2.375.4, and LTS 2.387.1 limits the number of request parts to be processed to 1000. Specific endpoints receiving only simple form submissions have a lower limit.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-frgr-c5f2-8qhh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-27900

Advisory: Denial of service in Jenkins Core
IDs: CVE-2023-27900, GHSA-frgr-c5f2-8qhh
Record: https://patchnext.com/advisories/cve-2023-27900 (revision 1, source checked 26 Oct 2026, 16:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.main:jenkins-core 2.394, 2.387.1, 2.375.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jenkins-ci.main:jenkins-core: affected < 2.375.4; >= 2.388, < 2.394; >= 2.376, < 2.387.1; fixed in 2.375.4, 2.387.1, 2.394

## Suggested inspection (read-only)
- Maven org.jenkins-ci.main:jenkins-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jenkins-ci.main:jenkins-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-frgr-c5f2-8qhh (GitHub-reviewed advisory GHSA-frgr-c5f2-8qhh lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=0 =2.388 =2.376 <2.387.1)

Commands are suggestions: review each one before running it.

Loading voting…