Airflow Sqoop Provider RCE Vulnerability
CVE-2023-27604GHSA-g3m9-pr5m-4cvp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-apache-sqoop 4.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow-providers-apache-sqoop
- Affected
- < 4.0.0
- Fixed in
- 4.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g3m9-pr5m-4cvp lists affected ranges: PyPI apache-airflow-providers-apache-sqoop >=0 <4.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g3m9-pr5m-4cvp lists affected ranges: PyPI apache-airflow-providers-apache-sqoop >=0 <4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-27604: 1.65% estimated exploitation activity in the next 30 days; percentile 76.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Airflow Sqoop Provider, versions before 4.0.0, is affected by a vulnerability that allows an attacker pass parameters with the connections, which makes it possible to implement RCE attacks via ‘sqoop import --connect’, obtain airflow server permissions, etc. The attacker needs to be logged in and have authorization (permissions) to create/edit connections. It is recommended to upgrade to a version that is not affected. This issue was reported independently by happyhacking-k, And Xie Jianming and LiuHui of Caiji Sec Team also reported it.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g3m9-pr5m-4cvp
- Revision 1 · created ·
Published from osv record GHSA-g3m9-pr5m-4cvp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-27604 Advisory: Airflow Sqoop Provider RCE Vulnerability IDs: CVE-2023-27604, GHSA-g3m9-pr5m-4cvp Record: https://patchnext.com/advisories/cve-2023-27604 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-apache-sqoop 4.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow-providers-apache-sqoop: affected < 4.0.0; fixed in 4.0.0 ## Suggested inspection (read-only) - `python -m pip show apache-airflow-providers-apache-sqoop`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow-providers-apache-sqoop. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g3m9-pr5m-4cvp (OSV record GHSA-g3m9-pr5m-4cvp lists affected ranges: PyPI apache-airflow-providers-apache-sqoop >=0 <4.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-g3m9-pr5m-4cvp (GitHub-reviewed advisory GHSA-g3m9-pr5m-4cvp lists affected ranges: PyPI apache-airflow-providers-apache-sqoop >=0 <4.0.0) Commands are suggestions: review each one before running it.
Loading voting…