Skip to content

← Actionable
Critical, CVSS 9.1

Full authentication bypass if SASL authorization username is specified

CVE-2023-27582GHSA-4g76-w3xw-2x6w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/foxcpp/maddy 0.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-27582: 1.02% estimated exploitation activity in the next 30 days; percentile 63.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact maddy 0.2.0 - 0.6.2 allows a full authentication bypass if SASL authorization username is specified when using the PLAIN authentication mechanisms. Instead of validating the specified authorization username, it is accepted as is after checking the credentials for the authentication username. Patches maddy 0.6.3 includes the fix for the bug. Workarounds There is no way to fix the issue without upgrading. References Commit that introduced the vulnerable code: https://github.com/foxcpp/maddy/commit/55a91a37b71210f34f98f4d327c30308fe24399a Fix: https://github.com/foxcpp/maddy/commit/9f58cb64b39cdc01928ec463bdb198c4c2313a9c

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4g76-w3xw-2x6w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-27582

Advisory: Full authentication bypass if SASL authorization username is specified
IDs: CVE-2023-27582, GHSA-4g76-w3xw-2x6w
Record: https://patchnext.com/advisories/cve-2023-27582 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/foxcpp/maddy 0.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/foxcpp/maddy: affected >= 0.2.0, < 0.6.3; fixed in 0.6.3

## Suggested inspection (read-only)
- Go github.com/foxcpp/maddy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/foxcpp/maddy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4g76-w3xw-2x6w (GitHub-reviewed advisory GHSA-4g76-w3xw-2x6w lists affected ranges: Go github.com/foxcpp/maddy >=0.2.0 <0.6.3)

Commands are suggestions: review each one before running it.

Loading voting…