Apache superset missing check for default SECRET_KEY
CVE-2023-27524GHSA-5cx2-vq3h-x52c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-superset 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-superset
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5cx2-vq3h-x52c lists affected ranges: PyPI apache-superset >=0 <2.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2023-27524 to the Known Exploited Vulnerabilities catalog on 2024-01-08.
VerifiedObserved Listed in the CISA KEV JSON feed; separate from customer applicability.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2023-27524 to the Known Exploited Vulnerabilities catalog on 2024-01-08.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2024-01-08).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5cx2-vq3h-x52c lists affected ranges: PyPI apache-superset >=0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 8.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L/E:H
- EPSS
- CVE-2023-27524: 98.15% estimated exploitation activity in the next 30 days; percentile 99.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Session Validation attacks in Apache Superset versions up to and including 2.0.1. Installations that have not altered the default configured SECRETKEY according to installation instructions allow for an attacker to authenticate and access unauthorized resources. This does not affect Superset administrators who have changed the default value for SECRETKEY config.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5cx2-vq3h-x52c
- Revision 2 · evidence added ·
CISA KEV confirmed exploitation for CVE-2023-27524 (date added 2024-01-08). Customer workflow unchanged.
- Revision 1 · created ·
Published from osv record GHSA-5cx2-vq3h-x52c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-27524 Advisory: Apache superset missing check for default SECRET_KEY IDs: CVE-2023-27524, GHSA-5cx2-vq3h-x52c Record: https://patchnext.com/advisories/cve-2023-27524 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: apache-superset 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-superset: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - `python -m pip show apache-superset`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-superset. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5cx2-vq3h-x52c (OSV record GHSA-5cx2-vq3h-x52c lists affected ranges: PyPI apache-superset >=0 <2.1.0 (fixed)) - Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2023-27524 to the Known Exploited Vulnerabilities catalog on 2024-01-08.) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2023-27524 to the Known Exploited Vulnerabilities catalog on 2024-01-08.) - Verified: https://github.com/advisories/GHSA-5cx2-vq3h-x52c (GitHub-reviewed advisory GHSA-5cx2-vq3h-x52c lists affected ranges: PyPI apache-superset >=0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…