Authenticated Local Privilege Escalation vulnerability in Intel Optimization for Tensorflow
CVE-2023-27506GHSA-m2f8-v8q4-3m59
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow-intel 2.12; intel-tensorflow-avx512 2.12; intel-tensorflow 2.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tensorflow-intel
- Affected
- < 2.12
- Fixed in
- 2.12
- Affected
- < 2.12
- Fixed in
- 2.12
PyPI intel-tensorflow
- Affected
- < 2.12
- Fixed in
- 2.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m2f8-v8q4-3m59 lists affected ranges: PyPI intel-tensorflow >=0 =0 =0 <2.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m2f8-v8q4-3m59 lists affected ranges: PyPI intel-tensorflow >=0 =0 =0 <2.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:H/A:L
- EPSS
- CVE-2023-27506: 0.16% estimated exploitation activity in the next 30 days; percentile 5.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper buffer restrictions in the Intel(R) Optimization for Tensorflow software before version 2.12 may allow an authenticated user to potentially enable escalation of privilege via local access.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m2f8-v8q4-3m59
- Revision 1 · created ·
Published from osv record GHSA-m2f8-v8q4-3m59
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-27506 Advisory: Authenticated Local Privilege Escalation vulnerability in Intel Optimization for Tensorflow IDs: CVE-2023-27506, GHSA-m2f8-v8q4-3m59 Record: https://patchnext.com/advisories/cve-2023-27506 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tensorflow-intel 2.12; intel-tensorflow-avx512 2.12; intel-tensorflow 2.12. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tensorflow-intel: affected < 2.12; fixed in 2.12 - PyPI intel-tensorflow-avx512: affected < 2.12; fixed in 2.12 - PyPI intel-tensorflow: affected < 2.12; fixed in 2.12 ## Suggested inspection (read-only) - `python -m pip show tensorflow-intel`: prints the installed version. Run with the environment that serves production active. - `python -m pip show intel-tensorflow-avx512`: prints the installed version. Run with the environment that serves production active. - `python -m pip show intel-tensorflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tensorflow-intel, intel-tensorflow-avx512, intel-tensorflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m2f8-v8q4-3m59 (OSV record GHSA-m2f8-v8q4-3m59 lists affected ranges: PyPI intel-tensorflow >=0 =0 =0 <2.12 (fixed)) - Verified: https://github.com/advisories/GHSA-m2f8-v8q4-3m59 (GitHub-reviewed advisory GHSA-m2f8-v8q4-3m59 lists affected ranges: PyPI intel-tensorflow >=0 =0 =0 <2.12) Commands are suggestions: review each one before running it.
Loading voting…